Ring doorbell 2020 doesn’t recognize plug-in

My ring door bell 2020 after hooking it up to the plug-in adapter from ring due to battery always dying, my doorbell won’t recognize the plug-in. Says there is no power to it, when it is on. The surge protector is turned on. So no issue with power from there. Any tips to get it to work? We did try to solar panels but nothing workEd with our door bell. Please help.

Hi @bbb6be695f7913e8a69d9ad21ee8eb. The Ring Plug-In Adapter (2nd Gen) should be compatible with the Video Doorbell - 2020 Release. Have you tried plugging the adapter into a different indoor power outlet? I would also recommend ensuring that the adapter is fully and firmly plugged in at both the standard indoor power outlet and on the Doorbell itself.

Yes I have and it still isn’t working. I’ve had to reset my ring camera more then once and it’s still not fixing the problem.

@bbb6be695f7913e8a69d9ad21ee8eb In that case, I would recommend reaching out to our support team so they can help take a further look at this and help get you squared away. You can give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support. :slight_smile:

The experts at RING don’t have a clue and really don’t know the difference between AC & DC…
You need an AC transformer, the Plug in Adapter DOES NOT WORK with this model despite what their support pages tell you….
There’s a sticker on the back of the doorbell that clearly states only to use an AC transformer and NOT a DC supply. The plug-in adapter is 24v DC and will not work.
You need to order the RING transformer and 25 ohm 50W resistor to charge your doorbell.
Ignore any advice from the RING help desk or any support pages…

1 Like

Thank you I will look into them!