Ring Doorbell 2 won't power on

Been using Video doorbell 2 for about 3.5 years now just on battery. Haven’t hardwired it at all. Worked perfectly fine up to a few days ago when i removed the battery as it had been drained out. Charged it up as usual and inserted it back into the doorbell. I noticed it hadn’t turned on i.e the light didn’t start blinking is it should. I checked the app and it said the doorbell is offline as expected. I have been using a solar charger for it as well and it also wasn’t showing connected. Could the battery be dead despite being able to charge to 100%. If so, how do i troubleshoot this issue? Any help is appreciated.

Hi @AhsenNadeem. How long did you charge the battery for? Typically you’ll want to charge the battery for about 8 hours using the provided charging cable with a standard power outlet. If you’ve done this already, I’d recommend trying a different power outlet. If the Doorbell still isn’t responsive after this, you can reset it by holding down the setup button for at least 20 seconds. This will do a full reset, and once that’s done, try setting the Doorbell up in the Ring App again. Let me know how this works for you. :slight_smile:

From what i remember, i charged the battery for about 8 hours until it was full. Haven’t tried a different outlet as of yet but will give it a shot. I’ve tried to reset the doorbell already but i don’t get a response after holding it for the required period of time. I’m assuming it can’t reset itself if it’s not getting any power, correct me if I’m wrong.

1 Like

@AhsenNadeem Correct, if the battery didn’t get a full charge the Doorbell won’t be able to process the reset if the battery that’s inserted in the Doorbell is dead. Definitely give a different outlet a try and charge the battery for 8 hours before putting it in the Doorbell and attempting the reset. Let me know how that goes! :slight_smile: