Ring doorbell 2 won’t power on

My Ring doorbell 2 (battery power) will not turn on. I have tried 3 different fully charged batteries. It does not power on at all.

Let me point out too, before someone ask—the batteries work in my cameras, so I believe it is something with the doorbell.

2 of the batteries are only 6-months old roughly. The doorbell is 11 months.

Hi @Matteblack13, nice job testing the batteries in the other cameras to make sure the batteries are working and ruling that out! If you can, please insert one of those batteries into the Doorbell, and try pressing and holding down the setup button for 30 seconds. This will perform a soft reset of the device and hopefully come back on. If the Doorbell still doesn’t have any signs of life or light, please reach out to our support team here for further troubleshooting.

I have the same problem with battery since I installed it. It is hardwired also. I don’t understand why I need battery if it is hardwired. Don’t make sense to me!