Ring doorbell 2 battery

Is there a way to disable the camera from getting automatic snap shots every minute? It’s draining my battery like crazy!


There sure is a way to change this @Butchoy! To change the frequency of snapshots captured, follow these instructions:

  • Open your Ring App.
  • Tap the three-lined icon in the upper-left hand corner of the app to open the side menu.
  • Tap Devices.
  • Tap the desired device.
  • Tap Device Settings.
  • Tap Video Settings.
  • Tap Snapshot Capture.
  • Select the frequency with which snapshots will be taken.

Check out our help center article about Snapshots for more tips on using this feature. I hope this helps! :slight_smile:

Hi! I followed the steps you outlined below. But there is no snapshot capture under my video settings so I cannot change anything. Please help!

Hi @Butchoy. Chiming in for Marley! When you go under Device Settings > do you see an option for Snapshot Capture? The settings options you have should look like how they are in my attached screenshot! From there you can turn off Snapshot Capture once you select it or recent how often it happens! Ensure you click save at the top right after if it pops up. :slight_smile:

Hi! There is no option for snapshot capture under the device settings. If there was, I would’ve seen it and turned it off a long time ago. Please help!


Hi! No option for snapshot under my device settings. Please see attached photo.

@Butchoy Thank you so much for that screenshot, and I apologize that it’s still not there! This is indeed odd, but we have another way you can turn off snapshots. This does require a bit more work to be done, but if you remove the device from your account, reset it and re-add it to your account, this will refresh all settings for it! If you can, go under General Settings and tap Remove This Device once you have ensured any videos you need are saved.

Once removed, press and hold the setup button on the device for 20 seconds to reset it. From there, re-set up the device as if it were the first time setup, and let me know if the Snapshot Capture option shows up for you, as well as if this feature is seemingly off (you may have to review your history in 24 hours to verify this).

That worked! Thanks for your help!

1 Like