Ring Doorbell 2 Battery Fully Charged but apps is showing 5%

Hi there, I have been using my Ring Doorbell 2 for a while and it has been working great. Recently, the app (on my Samsung phone) prompt me that the battery is low and requires charging. We charge the battery fully and reinserted it back to the doorbell but the app is reflecting the battery life as 5%. We tried installing and uninstalling the app several times but it still shows 5%. We also make sure that we charge the battery till it shows the green light only. What else can we do?

Hi @AlexK1. Thanks for listing out what troubleshooting steps you’ve tried so far. Since the Ring App is still reporting the incorrect battery percentage, I’d suggest resetting the Doorbell and taking it through a fresh setup. To reset the Doorbell, hold down the setup button for at least 20 seconds. Once that’s complete, follow the steps in the Ring App under Set Up a Device to complete the new setup.

The Ring App should now show the correct battery percentage. If it doesn’t, please give our support team a call at one of the numbers available here so they can take a closer look. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. :slight_smile: