Ring doorbell 1st gen light flashing blue

Unable to reset 1st gen doorbell because blue light is flashing (steady flash, not rapid). I’ve tried all the troubleshooting info, but the white light does not appear. After sitting a couple of days the blue light stopped, but I believe it ran the battery down because when I put it back on the charger, the blue light began to flash again. I have pushed the orange reset button, but it still is flashing blue after 2 days. I have reset and tested the router several times. Everything else is connected with no problem. This may have happened during a storm when the lights flickered on and off. Is it dead?

Hi @user55148. When factory resetting your Doorbell, make sure you are pressing and holding the orange button for 20–25 seconds. If you have tried this step and your Doorbell is stuck flashing a blue light, give our support team a call for further assistance.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.