Ring devices won't reconnect to wi-fi after power cut

My Chime (2nd Gen) and two new Floodlight Cam Wired Pro’s won’t reconnect to wi-fi after a power cut.

We had a short 15 second power cut to the house. After which my Ring devices won’t now reconnect to wi-fi (showing offline in the App and website account). But, my Video Doorbell 4 is fine. My internet connection is fine, so is my wi-fi as tested with my phone and laptop.

The Chime had been working fine, and the Floodlight Cam Wired Pro’s working fine for the couple of days they had been installed before the power cut.

I have tried the following, none of which worked:

  • pressed the button on the camera’s to enter setup mode, then pressed the button again to initiate wi-fi reconnection. The camera’s reported they had reconnected, but it hadn’t as it remained offline in the app.
  • attempted to reconnect through the app, reselecting wi-fi point, re-entering password. But, it times out and reports unable to connect.
  • removed the devices from the app to try adding them again.
  • Reset one of the cameras back to factory default by pressing the button for 20+ seconds. Then restarting setup again. I can connect to the device setup wi-fi ok, then the device is able to scan and detect my wi-fi points. But, when I select the wi-fi point and enter the password, it fails and reports unable to connect to the wi-fi point.
  • did the same factory reset for the Chime. Tried to re-add the Chime in the app, but fails to connect and reports ‘something went wrong’ in the app.
  • I have restarted the router.
  • I have restarted my wi-fi point (the same one that my Doorbell works fine with).
  • My router shows the camera which wasn’t reset, connected to the wi-fi point. But the camera remained offline.
  • Deleted and re-installed the app.

What else can I try?

Hi @JARW. It sounds like you’ve covered most of the basic steps I typically suggest. One thing you can try, would be to connect your camera to a wifi hotspot. Once you are online with the wifi hotspot, go into the Device Health section of the Ring app and select Change my WiFi network. If you are asked to join a previous network, select NO and enter all of your wifi information in manually. Let me know if this works!