Ring Chime only working about 20% of the time

Hours have been spent on the phone to Ring.
I have tried literally everything my end, even created a new temporary account and tethered from my phone. Still the same. Ring has sent out £100’s of equipment that I didn’t need… We are all having the same problem. Before 3 weeks ago, our Chime didn’t miss a single bell press in 2 years. Now it’s working less than 50%. We have many more Ring cameras and pay for the Protect plus yearly. Well that’s up next month, and I have ordered a new Google Hello doorbell. Before this, I was very happy with Ring, and would recommend it to anyone. Now it can’t even perform the very basic function of ringing a chime inside - something a basic doorbell can do costing around £10. If this isn’t sorted within a couple of days (when my Google doorbell turns up), then I will cancel everything with Ring and sell off all the equipment. THREE WEEKS without a reliable doorbell isn’t good enough. It’s all very well saying they’re looking into it, but it needs to be sorted - and why does their status page say no reported problems? And 100% up time for the whole of January and February??
If you’re reading this and work for Ring, please pass this info on to the relevant departments. Before I pull the plug on all of it!

1 Like

A post was merged into an existing topic: Chime Pro 1st gen and Chime no sound when doorbell pressed