Ring Car Cam will Not Go Into Setup Mode

I have tried to get my Ring Car Cam to work, but not having any luck. It is plugged into the ODB port. The blue light on the OBD light comes on when I plug it in. Hook the camera up, but I never get the pulsing green ring. If I hold the button down the ring lights up green for a second or two, then goes out. I have tried disconnecting everything and trying again. Tried waiting 15 minutes. Nothing. Yes, my car is turned on during this process. I have tried multiple times with no luck.

I am guessing either my ring is bad, or it doesn’t work with my car. My car wasn’t listed on Rings list because they don’t list any 2023 cars. So I took a chance since I wanted to get the $199 deal before it ran out. My car is a 2023 Kia Sportage Hybrid. You can’t get more of a modern car with fresh batteries since it is only a few months old. The OBD is on the left side of the steering wheel. So again, not sure if I got a dud, or the Ring Cam doesn’t work with real new cars.

Any thoughts I what I can try?

I’ve the same problem. Have you solved the issue?

Nope, no resolution yet.

Hi neighbors. When setting up your Car Cam, make sure your vehicle is parked in an area you have good wifi or cellular connectivity. To reboot the device, hold down the button within the circular status LED atop the device for 7 seconds. The light will quickly flash green and reboot, which takes between 20-60 seconds.

Additionally, make sure your car’s battery has enough charge before attempting the setup process. Try driving your vehicle for about 30-60 minutes to ensure the battery is charged. If this concern persists, please give our support team a call at one of the numbers available here for assistance with setting up your Car Cam. If you are outside of the US, please visit here to see how to contact support.

Thank you for your response. I have unchecked the solution button since this is a caned response without waiting to see if it actually resolved the issue. You should actually probably ask the person before marking it as a solution. Very rude.

As to your suggestion. One, I have rebooted the thing until I am blue in the face it doesn’t do anything or change the situation. I have plenty of cell signal where my car is. I also have plenty of wifi signal. However, what good does wifi signal provide if your device isn’t even getting to the point where I can configure the wifi???

As for confirming my car has enough battery, my car is 3 months old (brand new) and has no issues with the battery. Even tried again after getting home today from work (more than 1/2 hour drive). Still same result as before. I do not get the pulsing green light that will allow me to configure it.

Your response suggests you didn’t even read my post. I appreciate the response. However, unless you have something else to suggest, I am not calling your support so they can say the same things I have already tried. I am not wasting any more time on this product.

I am just returning it. It is not ready to be sold yet. Maybe when gen2 is out in a year or two I will try it again when it actually works.

1 Like

I’m getting the exact same behavior. I ended up pulling the camera off my window to make sure my cabling wasn’t bad. It worked for me after multiple tries so I reattached it to my window. After letting it sit overnight it would not connect so I removed it to try and reinstall it again.

Now it no longer works…. The green light comes on when I hold the button but will never start flashing. I’m guessing the unit is bad and will be returning in short order if there is no response in here from customer service. It looks cool but seems like it’s really not ready for release….

Hi @user37858. If you haven’t done so already, try driving your vehicle for about 30-60 minutes before attempting the setup process again. Then reboot the Car Cam by holding down the setup button on the top for 7 seconds. Keep in mind the reboot could take a minute to complete. If you’re still not able to get your Car Cam up and running, I’d recommend following up with our support team at one of the numbers available here for further troubleshooting assistance.

Anyone find a solution yet? My car cam worked fine up until a couple days ago. It reconnected itself once, but now it no longer connects. It says it has strong signal too. The cam won’t go into setup mode and pulse blue. Frustrating.