Ring cannot reconnect after WiFi reboot

I have the 2020 issue of the standard doorbell 2.
My WiFi router automatically reboots at 4am each night as part of its health routine. Most nights the doorbell has no issue reconnecting. But 3 times now in a month it won’t reconnect. I need to reset the wi-fi router even though connection is fine with all my other devices. I won’t be able to reset the router when I’m abroad though. So it’s not ideal situation.
Connection strength is very high so that’s not the issue. I read in other posts that the wi-fi password cannot use special characters like !. Is that the case? Or perhaps it’s the channel selection is the issue? Either way there is a limitation here with the device… Can you advise what I should do? No special characters in WiFi password? And no multi channel connecting on 2.4ghz? Please advise as this is very frustrating.

Likely its your WiFi. Move a WiFi access point closer to your doorbell, as a test, and see if you get better reconnection upon reboot of the router.

I reset my WiFi password to remove special characters and reset the ring doorbell.
I’ll see how it goes in the coming weeks… As I’ve said it’s only happened 3 times in as many weeks. Always at 4am which is when my wi-fi router rebooted.
The RSSI is 50! So excellent connection. Door bell is only 12ft from router and line of sight through glass, so it’s 100% not a connection strength issue.

Outside walls are notoriously bad at getting a WiFi connection through.
If you are unwilling to do a simple test then I won’t be able to assist.

Good luck!

1 Like

I’m very willing to do every and any test to get this fixed. I’ve just physically removed my WiFi access point from the wall and positioned it under my ring door bell in my porch. It’s now 2 feet from the ring door bell with no glass or wall between them.
Connection shows as very good in the ring doorbell health check. What should I do next? Thanks for your help. It’s very much appreciated.

Hi @user18144. Good call on the troubleshooting steps you’ve tried so far, such as removing special characters from your wfii password and moving your wifi access point closer to the Doorbell. If the RSSI on the Device Health page looks good, this should indicate a stable wifi connection. If possible, I would recommend disabling the automatic reboot on your router when you’re abroad. That way you do not have to worry about the Doorbell having to reconnect to wifi on a daily basis when you aren’t there.

That’s a really helpful suggestion! Thanks Caitlyn. I’ll do that before I go abroad just as a fail-safe… Thanks!!

1 Like

One final comment… It happened again last night so there does seem to be a device issue with reconnecting to wi-fi once connection is lost due to reboot or power outage etc.

Here’s what I did.

  1. Moved wi-fi router directly under bell so RSSI was 40 and connection was excellent. No walls or interference.
  2. Changed my WiFi password to remove special characters and reset my ring doorbell and completed setup again.

Issue still occurred.

I will disable my WiFi router from completing it’s nightly reboot at 4am. I can tell from my 5 minute ring snapshot setting that this is when the ring doorbell goes offline. 4am.
This didn’t happen for the first few weeks of ownership of the ring doorbell so I’m wondering if a firmware change happened.
Either way, the ring doorbell should be able to complete a reconnect because my my WiFi is fine for every other device and is back online 2 or 3 minutes after reboot. It’s like the ring doorbell gives up trying to reconnect and that’s it. It should be able to try a reconnect start ten minutes and twenty minutes and thirty minutes before giving up.

I hope this is helpful to your technical department. In the meantime I’ll disable my wifi reboot as suggested, but that won’t help with internet or power outages…

Thanks for your help…

A final piece of information that may help the technical software team.
When there was motion at my front door the bell came back online and reconnected.

I could not force it to reconnect from the app and I could not see live view before this etc. It was disconnected. The manual reconnect to WiFi option in app didn’t fix this. However when there was motion at my door it appears to have reconnected and I got the notification and now it’s back online.

I think this information can help the software team understand how the manual reconnect differs from the motion detected reconnect and can find a solution…

Unfortunately I’m abroad and the bell is offline again. Technical support really need to try a 30 or 60 minute auto reconnect if there is a loss of wi-fi or a power cut or wi-fi reboot or outage. The WiFi name and password has not changed. Other devices reconnect without issue. The ring doorbell needs me to be physically present to remove the bell and press an orange button. Not great. It should try to auto connect to last WiFi surely. Try and try automatically. Not just give up and stay offline.
This would put me off this device and product. It needs to be more resilient to a power cut or wi-fi restart. Firmware can address this.

Same problem. I’m out of town, rebooted the router remotely but Ring doorbell not coming back online. :face_with_symbols_over_mouth:

1 Like

My ring doorbell came back online.exactly 24 hours after it went offline. My router was back online within minutes when the outage happened - so I suspect the ring doorbell didn’t try to reconnect until 24 hours later. Hmm… I think the ring attempt to reconnect using the same wi-fi name and password should happen every 5 minutes initially after an outage, and then every 30 minutes after an hour of trying etc. Firmware can address this. Waiting 24 hours to try to reconnect again is too long. I lost a day of cover and security.

Very happy to know this affects others too. Might be a chance ring will address it.