Ring Cam Wired wont reset or connect wifi

I have tried everything. Guide through the app wont fix anything. Reset with 20sec method on top of unit wont reset.

Im stuck.

It lights green and has the led running all the time. I have to unplug it from the socket since its lid all the time.

Wont connect to wifi.
Wont reset.
Wont do anything.

Its like its in some bricked state that reboots the same state over and over again.

I tried unplugging it for several minutes hours and days.

I tried rebooting my wifi.

I tried turning off my router for several minutes.

I tried the reset button (20 sec press)

I tried the connect button (single press)

Is it really not possible to get some real help from a human support of the company?!

Only 1 photo per new user? Im not a new user!!

Hi @RingUser31. You have tried all the basic troubleshooting steps I would have recommended for your concern. The next best step would be to give our support team a call at one of the numbers available here for further assistance. If you are outside of the US, please visit here to see how to contact support.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.