Ring Battery won't Charge

I have the Ring Battery Doorbell Plus, which i bought in the summer, which has now stipped charging. I plugged it in, the charging lights came on, but after 15 hours, it was still an ora ge light, i put the battery back in the doorbell, and it was still on 6%!

I changed outlets and tried again, leaving it to charge overnight, but again it’s still only saying 6% when i put it back in.

This is the only rhe 3rd ever timenive charged it, and is only about 5/6 months old. Please help?

Exact same thing happening mine , took battery out fully charged , replaced and still nothing ! Just all of a sudden this happened . Lost without it ESPECIALLY AT THIS TIME OF YEAR :sob::sob::sob:

Hey neighbors, I’d suggest reaching out to our support team regarding this. If you have plugged the battery into a standard outlet with the provided charging cable, and it does not appear to be charging, there may be an issue with the battery itself. When the battery is charging, there should be a green and orange LED on the battery, and only a green LED when it is done charging.

Same issue here. Third charge I think since new. Battery on overnight and still has a green and amber light. Tried 2 different cables and plugs. Reinserted battery and app still saying 18% battery.

Hi @user73348. You want to make sure your Doorbell is online as well and that you are able to use a Live View. If it is online and that battery shows it did not charge after it was plugged into a charger for a few hours, give our support team a call for further assistance.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.