Ring Base Station lost wifi connection

My Ring base station started to complain that it has lost internet connection. Reconnect from the app didn’t help. I pushed reset button on the device and it fixes the problem. I observed this problem 4-5 times last week. I have never seen it before (using Ring for a year now). Other devices don’t have any problems with wifi. Wifi signal is very strong at that spot. Firmware is up-to-date.

How can I open a ticket with Ring to diagnose the issue?



Glad you asked @sergey! One thing more I’d recommend here is to try using ethernet connection rather than wifi. This will give you the most efficient network connection. If this concern persists, our support team is always here to troubleshoot more in-depth to find you a solution. Feel free to keep us updated on the results! :slight_smile:

Seriously that’s the answer? Don’t use WiFi? We recommend Ethernet? This is the 2020’s not the 1990s.

I have the same problem. Ring Base station connected for months with no issues, suddenly won’t connect to my WiFi - every other device (more than 43) connected with no issues.

Tried reset, power off, nothing. Any help here Ring?


Hi @bdkFL99xx. This can usually be fixed with a quick reboot of the Ring Alarm system. To do this manually, simply get a paperclip and give the “Reset” button on your Base Station a quick tap. It is important to NOT hold this button down, and to just press and release it. After your system reboots, it should automatically sync back to your wifi connection. I hope this information helps.

Had same problem. Wifi disconnected and setup in the app refused to connect to any wifi network. Tom’s answer worked and the base station rebooted and reconnected to the wifi network it was connected to previously. No need to reconfigure. (App was in the middle of configuration - had to cancel it)

But why was it needed in the first place?

1 Like

Annoying same here

Wasted 30 minutes… but now fixed

Same thing, it happens at random. And it is not reliable.

I hope this is not happen when we travel outside.
Otherwise This ring will not be reliable


Same here. Unable to connect to wifi after hours of effort. Support has been no help. Told me it’s my router but everything else in my home connects with no issues.

1 Like

I started getting this same problem recently, there are no connectivity issues on our WiFi network.

I can see the Ring base associated with the access point, but the problem seems to be that when the code is doing a dns lookup it uses the wrong MAC address, not the WiFi MAC address showing on the base sticker which matches the one shown in the access point association, this triggers a firewall rule that detects spoofing then the UDP packet with the DNS search gets dropped and the base reports loss of connectivity and switches to cellular backup.

The target IP address the base uses to send the UDP dns lookup (port 53) are,, and

Will the base assume that it lost connectivity if the dns lookup does not work?

I have not tried using a wired connection yet.

I will try to contact support and open a ticket.

Thanks & Regards, Jorge.


I recently (last couple of days) have been frequent periodic alerts that my system has lost connection as well. It will reconnect within a hndful of minutes every time. I am on wifi and would really rather not have resort to hardwiring. Other devices have consistently worked over wifi while the system is reporting down. I have already cycled power on the base station.


Hi neighbors! If the previous troubleshooting suggestions offered in this thread do not work, please give our support team a call at one of the numbers available here. They can take a deeper look for you and make sure your Base Station is working properly. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

Same issue. Works after a year then suddenly disconnected in the middle of the night. No issues with WIFi network or other devices connecting to WiFi.

Soft reset, re-pair mobile app to base station then re-enter WiFi credentials did the trick.

Clearly seems to be a product issue someone should look in to. Would hate for this to happen while people are away and cannot perform a soft recent remotely or again in the middle of the night when families are sleeping - when Ring is needed the most!


@jmamodio Did you get anywhere with the ticket regarding the DNS problem?

1 Like

Any response from support would be appreciated. This is obviously a software issue for it to just start happening after a year and with multiple users experiencing this.

1 Like

I have the same issue now for the second time. First time i was at home and i pushed the reset button - that worked. But know i am away for a month and i can‘t push anything. What can i do? Can i setup the network from away? Or do i have to be in the same network? I am very disapointed.

1 Like

Just a random guess here, but do any of you have comcast internet with the xfinity xfi gateway? It does not play nice with foreign wifi devices and will randomly drop them. Use ethernet.

1 Like

I had the same issue. I just rest the base but all devices are not responding. Extender, keypad and sensors. I can see them in the device list but no answer at all

Same here, the base list wifi and it says it can’t see the wifi network. But with the phone right next the base, the phone has full strength WiFi signal

I’ve recently bought a ring alarm (2nd gen) and am having problems with it randomly disconnecting from my wi-fi.
Pressing the reset button worked but only for about 5 days and it’s disconnected again!
No other device on my network is having any problems with wi-fi.

Any help please?


Hi neighbors! When a Base Station falls offline it is often due to network connection or power variables. Depending on certain factors you can confirm this based on the backup response from your Base Station. For instance, if your Base Station falls offline and starts using battery back up, it may be power related.

In any case, it’s best to check wifi connection in the area of your Base Station, and ensure there are not any major appliances or electronics that might be interfering. I recommend connecting your Base Station to Ethernet connection for best results. Here is our Help Center article on how to do so.

If this concern persists despite trying the above steps, our support team will be happy to take a closer look for you. Please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support. :slight_smile:

1 Like