Ring base station keeps dropping wifi

For past couple of months my ring base station (2nd gen) keeps dropping the wifi MULTIPLE TIMES A DAY. As soon as I do a manual reset, it connects back again. I even have a range extender installed.
Rest of the ring products (doorbell, spot light camera) and 20+ other smart products are connecting to the same wifi just fine though out the house.
connecting with an ethernet cable is not really feasible.
What could be the issue and what can I do to resolve it?

Hi @user25674. You can also try these additional steps if your Base Station is continuously falling offline:

  • Verify that your Base Station is not around any objects that could interfere with its wifi signal, like TVs or major appliances.

  • Ensure that your Base Station is not too far from your Wi-Fi access point. If you have a multi-level home, the Base Station should be on the same level as your wifi access point.

  • Reboot your router by unplugging it for 10 seconds and plugging it back in.

We also have this Help Center article here with other steps you can try for devices that keep falling offline. If you have tried these steps and are still having the same concern, give our support team a call at one of the numbers available here for further assistance. If you are outside of the US, please visit here to see how to contact support.

My mother in laws Ring Base Station (GEN 2) is also disconnecting from the Wifi multiple times a day. Everyday my wife and myself have notifications from her Base Station disconnecting and working on cellular and then notifications of it having the signal restored. It is connected to an Eero Mesh 6 and they sit right next to each other. Nothing else in the house has wifi issues. Rings Cameras all connect to the Eero network with ease but the base station refuses to stay connected to the network. We have tried connecting through an ethernet cable and nothing. There has to be a firmware issue as it cannot just be a wifi and network issue for everyone having this issue.

Hi @DevTech86. Try connecting the Base Station to a dedicated 2.4GHz network. If your network configures devices to join the best available WiFi network (2.4GHz or 5GHz), it can cause your Base Station to go offline repeatedly. Let me know if this helps!