Ring app won't open on phone and my doorbell doesn't detect activity

I have a ring doorbell and just recently my app won’t open on my phone and I don’t get notified when someone comes to my door. It worked perfectly until 2 weeks ago. I’ve had the doorbell for 15 months. I also called ring customer service and after trying a few things and 1 hour later. Nothing worked. I reaching out to my community. Thanks for your help.

Hey @Zac1. Have you tried removing the app, rebooting your phone and then reinstalling the app? This could help fix any errors there may be on your app. Please also make sure you have the most updated OS on your phone as well. If you still cannot open the Ring app, could you attach a screen recording of what it looks like when you try to go into the Ring app? This will help show what’s happening so we can dissect it further!

Yes, I’ve tried all of that and multiple times. Deleted app-then re-installed, rebooted, up to date on the latest iphone software. It doesn’t make any sense!

@Zac1 What version of the Ring app are you using, your iOS version, and your iPhone’s build (6, 7, etc)? Additionally, since you are on iPhone, could you grab a screen recording of what happens when you try to load the Ring app? Preferably attach the video file to a reply here, or upload it to Youtube and share the link here. You can email this screen recording to community@ring.com if this is easier too.

Chelsea: I don’t know what version the ring app is. I can’t open it. It’s "ring always home " is all I can tell you. I click on the app it comes up for 5-10 seconds and then goes back to my screen with all my other apps. My Apple Iphone is a 6S and the IOS is 13.4.1

I sent in the screen recording last week and they couldn’t help from that. I just emailed it to you again.

It’s obvious from @Zac1 previous reply, that by uninstalling it and reinstalling it, that it has the most recent update.
I’m having similar issues also, they don’t care and can’t read either.

@Zac1 Thank you so much for emailing that to me! I will attach it in my reply here as a zip file so other neighbors that may run into this can see this as well. It definitely does not load past the home page, so I wanted to see how far it tried to load in. I’ve passed this along to the appropriate teams who say that they are investigating the matter of other iOS neighbors having the Ring app do this on the 13.4.1 iOS software. I personally am on 13.3.1, which may be why I have not ran into this myself.

After a bit more research, it looks like 13.4.1. is a beta version of the iOS software. Since our Ring app is not compatible with new beta softwares that we have not made the app compatible with yet, this is why the app could be crashing. I recommend to revert back to 13.3.1 and not be in the beta iOS to resolve this concern! @SonnyBlack If you have the same beta software iOS, please do the same. :slight_smile:

I have Android, can’t revert back. The new update on April 11th is horrible.

@SonnyBlack Have you tried removing, restarting your phone, and then reinstalling the app? Just want to ensure this has been done. Also, what is the OS version of your Android phone’s software and what kind of Android phone are you using? I assumed when you said your symptoms were the same as @Zac1, that you also were using an iPhone. For the screen recording I shared, does your app preform the same way when you try to go in it – it doesn’t load past the splash page?

That makes sense except I don’t have a Profiles & Device Management on my phone after I go to settings and General.

@Zac1 I see what you mean! I also do not see this on my phone. It may be a bit dated of an article. Could you reach out to Apple support to see if they can assist with reverting back your software?