Ring App (V2.5.0) on Mac 10.15.4 - Microphone not working

Hi all,

i have installed the ring-app (V2.5.0) on my mac (Catalina, 10.15.4). The app is working fine – but I cant speak with the persons at the door (but I can hear them)… In my systemsettings/Security/Privacy/Mic there is no ring-app, where I can turn on mic.

Any help?

Hey @Andreas. You will need to open up the Ring app on your computer, hover over Ring at the top left of your screen, tap on preferences, and from there you can adjust the input and output devices. :slight_smile:

Hi Chelsea,

of course i tried that before my post - but that is not the solution… Now i found out, that the version 2.5.0 & 2.5.1 has a bug. I deinstalled that version and download the version 2.4.2 from your homepage - this version runs fine - no worries with mic…



I’m having the same issue. Where can I download the old version. I can find it anywhere on the ring page.

Wait who marked this as “Solved” This is far from solved. To mark this solved you need one of 2 things.

  • A guide to downgrade to 2.4.2(the working version)
  • a update to 2.5.2 with a fix (2.5.1 still has the mic issue)

@Chelsea Please follow up with this. The ring app DOES NOT deserve 2.8 stars on the Mac App store just because of bad support.

I’m not seeing where I can downgrade or upgrade. Just … wait?

I’m seeing this same issue on my mac. OS is Catalina. Is there a solution?

Hi there, @toneprod! In addition to the recommendations above in this thread, please also ensure there is not a vpn enabled on your device.

This is still not working. How to I downgrade the app to 2.4.2

I don’t have a VPN

still doesn’t work, one year later…
Does RING have any plan solving the bug?