Ring App using mobile data while connected to Wi-Fi

I’ve recently begun experiencing a major data usage bug with the latest version of the Ring app. Basically, even when connected to a strong and reliable Wi-Fi connection, the app uses mobile data to access/stream the camera feeds. Before finally realizing there was a bug in the app, I burned through over 3 GB of data in two days. I have been using the Ring app on this same phone with this same mobile carrier for years with no previous issues.

Today, I further tested the issue by installing a 3rd-party data monitoring app. I then viewed my Stick-Up Cam for about 5-10 seconds using the Ring app while sitting at my desk connected to Wi-Fi. Sure enough, the data monitoring app immediately showed that the Ring app consumed over 5 MB of cellular data as well as a small amount of Wi-Fi data.

Watching a 20 second YouTube clip or browsing Chrome just a few seconds later used zero cellular data, as expected, according to the same monitoring app. Interestingly, using the “Rapid Ring” app does not consume any cellular data, so the bug is limited to the full Ring app.

This really needs to be acknowledged and fixed by the Ring team. There are numerous other threads in this community as well as on Reddit describing the same problem. My 3 Ring cameras and Ring Protect Plus plan are now basically useless, and I’ve had to shell out additional money to replenish my mobile data allotment that the app consumed.

Pixel 3a / Android 12 (November update) / Ring App 3.45.1

4 Likes

Hi @Padawan. Thanks for bringing this to our attention. I’ve shared this information with our internal teams for further review. I don’t have any information on this concern at this time, but a member of the Community team will update you when applicable. If you have any other questions in the meantime, don’t hesitate to ask!

1 Like

The attached snapshots show what I’m seeing on my mobile device – not as bad as with some Users, but definitely a matter of concern.

Here is a link to a discussion about many other users experiencing the same problem:

1 Like

Padawan-- Thanks for consolidating pertinent discussion threads and for your independent investigation.

Tom_Ring-- Your posted response is also appreciated. Once the issue is resolved, it would be beneficial for a member of the Ring Community team to update all affected Users who are following this discussion thread through a follow-up post, particularly since Users mobile data plans are being affected.

1 Like

I am also here to report this exact same issue with Android 12. I just switched phone from version 9 and there is absolutely something wrong with the app, it just burns through mobile data even when on Wifi.

Please resolve as quickly as possible and post here when a new version of the app with a resolution has been released.

2 Likes

My Ring isn’t connecting to wifi FIRST while at home. I have a Samsung Galaxy and when I open one of my cameras, it shows my wifi at full strength and my data 4g both open - and it connects to my data while at home. I have to shut off my data because it’s using up my monthly plan in a few days!

1 Like

Just downloaded the November 11th update of the Ring app and unfortunately it still suffers from this same bug. Even on a strong WiFi network, the app is streaming over cellular data.

1 Like

I am experiencing the exact same issue.

Pixel 4 / Android 12
Ring App 3.45.1

Unfortunately, by the time I remember this is occuring, I’m already below 10% remaining on my mobile data plan. The only thing I can do is go into the Verizon LTE settings and disable mobile data completely (when I am home and on Wi-Fi) but this is a major inconvenience.

2 Likes

It’s really unbelievable that Ring refuses to provide an update on a critical issue affecting its users.

1 Like

Same issue with me. Just spent 1/2 hour with customer service. Frustrating that they don’t get it!

2 Likes

@Marley_Ring @Tom_Ring You suggested in another discussion thread about this same issue that users should contact Support. Unfortunately, as noted above, Support is unable to provide any real assistance here.

1 Like

@Marley_Ring @Tom_Ring I began experiencing the same issue in late October, with Ring switching to cell data to play back video on my android. I had to spend $40 purchasing extra cell data to get me through the month. Please address the Ring issue as soon as possible.

3 Likes

This post was deleted.

Just starting using Ring yesterday and noticed immediately my data plan was being used during Live Streaming, using a Samsung Galaxy S9. The data plan is used if I’m on 2.4GHz or 5GHz wifi. If I disable my Mobile Network, then Live Stream will use my home wifi network as expected.

At this point I will only Live Stream from my PC or disable my Mobile Network, however disabling my mobile network really isn’t an option as I’ll miss calls/texts and such. I have a couple old burner-phones laying around with no data plan attached, so I might use one of those in the meantime.

Would be nice if this was fixed…with a Teen in the house, my mobile data is too valuable to waste.

Thanks

3 Likes

seanwil545 – As another interim alternative, you might want to try the Live View feature on the Rapid Ring app which doesn’t appear to be affected by the unresolved Ring app WiFi/mobile data issue.

There is no ‘bug’ persay within the app; one of ring’s default permissions is WiFi Control. Whenever I get or upgrade a phone, I always go through apps permissions and disable any unnecessary and/or intrusive permissions. To disable Ring’s WiFi control permission you’ll need to do the following:

-Settings
-Apps
-3 dot button in upper right hand
-Special Access
-WiFi Control (scroll down and it’s the very last option)
-Search (magnifying glass icon) and type in Ring
-Click on Ring to go into toggle menu
-Toggle off the option for Ring to turn on and off WiFi.

The other thing to check as well is to long - press the wifi button to bring up wifi networks and click the 3 dot icon in upper right hand corner
-Advanced
-Switch to mobile data (toggle on or off according to your preferences).

Attached a screenshot(s) as well, but hopefully that helps

1 Like

(in reference to the post directly above this one ^ )

Firstly, it appears you are using an iPhone. The controls you mention aren’t available to switch off in Android 12 (and probably not in other recent versions).

Secondly, your assumption that because you have these controls that means there is no ‘bug’ shows your ignorance about app and mobile phone development.

I would caution you not to come to conclusions based entirely on your own anecdotal experience and without educating yourself on the subject further.

5 Likes

Steps to reproduce issue:
Opening Ring App and navigating to wired camera while selecting live view initiates a live stream over celluar data. The device is on wifi with a strong connection. Disabling celluar data on device the live stream utilizes wifi. Celluar data in my area is not good. Attempted on multiple iOS devices with the same result. Additionally attempted on multiple Ring cameras with same result. Data traffic flow can be verified on iphone and also traffic monitoring on home network.

Expected result:
The app should utilize wifi connection while device is connected to wifi. Disabling celluar data is a workaround only and not a solution.

What is the expected timeframe to acknowledge this issue and eta for resolution? I have attempted to contact Ring support and they cannot provide me with an incident number, which is a bit concerning. I am looking for comment from an official Ring employee so this issue can be officially tracked and resolved.

Additional info:
iPhone 12 Pro
iOS 15.1.1
Ring latest version as of 12/6/21

2 Likes

Unfortunately, it’s been obvious that Ring has no intention of updating customers on this issue, and likely very little interest in resolving it.

@Marley_Ring and @Tom_Ring were unable or unwilling to escalate this and suggested contacting Support, which numerous users have done with zero results. I’ve also emailed the app developer contact email twice and not even received the courtesy of an acknowledgement back.

Right now the app is virtually useless for its intended purpose, while I (and many others) continue to pay Ring every month for a “premium” subscription.

The fact that I have hundreds of dollars of Ring products installed and cannot even get a basic update on this known issue from any Ring employees is disappointing at best. I’ve been in the software industry for almost two decades, and can’t fathom simply ignoring a major product issue and customer concern like this at my company.

3 Likes