Ring App uses 'in-call' speaker - can this be changed?

Hi all,

When answering a ring via android app on Galaxy S9, the call volume is played through the ‘in call volume’ speaker, e.g. the speaker at the top of the handset designed for use during phone calls.

As a result I can’t hear the person at the door unless I hold the phone to my ear, defecating the object for having video. Does anyone know how I can play the in call audio through my main phone speaker?

Thanks in advance!
Jamie

4 Likes

Jamie, bc you have a newer Galaxy phone, you will see a thread dealing with this. It is a problem across the board with our phones and the ring app. The newer android phones have multiple microphones and it is not a mic from the bottom as in an IPhone. Because of this the sound gets distorted. If you will search the thread dealing with “Ring 2 audio problems”, you will see you are not alone. We are all waiting for a fix! My Ring audio works fine through my IPad and Echo Shows, but I have the Galaxy 10 +, and my husband has the Galaxy 8+ and we are both having issues. Wish I had an answer for you…:neutral_face:

4 Likes

Having the same issue. Samsung Note 9. I’m assuming that this “Fix” still hasn’t released…? I have troubleshot this issue for far too long now. C’mon RING, I can’t possibly be paying for your services to have minimal functionality…

4 Likes

Totally agree!

come on ring, get this figured out

Yes same issue here on my s9. Come on ring you can do it!!!

Samsung galaxy s10 same problem. This is an old problem now. When can we have a fix?

Wow, what’s up Ring moderators, as folks seem to be posting about this for at least a few months? Makes me glad I’m still on an old galaxy S5 phone.

I ran across these posts while wondering why I have no choice about where the Ring audio comes from on my phone. Wouldn’t it be a good solution to allow you to select between the speaker and the more private speaker that goes next to your ear? Like a regular phone call allows. In this way I could at least have some privacy if I am “answering the door” while I’m in public with other folks around.

Just a thought.

Another idea - as a temporary workaround - for those using phones, have you tried using a headset? I know that my S5 (which admittedly does not have the problem since the sound eminates from the internal S5 “speakerphone” speaker) I can plug in a headset and the Ring session audio moves to that headset. Perhaps a bluetooth headset would also work. Not a convenient solution however for the Note users / tablet users :frowning:

1 Like

I see a lot of people are having the same problem. I have the galaxy S9+ and found out the problem is the bluetooth button. My ring was working just fine until I bought a galaxy watch. Turned my bluetooth off and I can hear the ring from the speaker.

2 Likes

I have the very same issue with a Galaxy Note 10+, is it a Samsung brand related issue?

Anyone who had this figured out? It is pretty anoying!!

I also have a galaxy watch, turned off bluetooth and then ring would work on speaker phone.
Please ring team try to fix this up, I dont want to have the need to turn off bluetooth every time I have a ring alert.
Thanks

Same with my Samsung phone and it’s so annoying. How is this an issue today with smartphones? It appears to be Samsung related.

I know this question is old but it seems like people are still having issues as was I. I just fixed mine. Not sure if this will work for everyone else but I wanted to share anyways. I downloaded the Samsung smart things app for the new TV I purchased about 2 weeks ago and after my speaker stopped working on my S10+ I tried everything and nothing fixed it. I opened my Samsung smart things app and noticed my ring doorbell 2 was part of my devices listed. I clicked on the play button in the video and turned the speaker on. After changing that setting and then going back into the ring app and turning on the speaker I could hear it loud and clear. I hope this helps someone cause it’s frustrating not being able to hear like your supposed to when communicating.

1 Like

I tried this. Sometimes it works normally through my speaker on my phone with Bluetooth on sometimes it doesn’t work. Turning Bluetooth off gives me the same result. It’s extremely annoying to have bought this to not have 100% functionality.

Same on Google Pixel phones. Inise a Pixel 4 XL my wife has a Pixel 4. Same thing.

(sigh) I wish Karissa83’s solution worked for me. Everything seemed like it would but my volume is still relegated to the in-call (upper earpiece) volume. Terrible.

The only solution I have found is that if you have a bluetooth ear bud or other wired attached AT THE TIME that you launch the ring app, you will get the expected outcome. Otherwise, be prepared that the person at the door will not hear you and you will barely hear them.

i have the same problem. Can anyone help me?

Telephones S9, Note10+ and S5e

I have tried the smart things, the doorbell works seamlessly regarding the sound via smart things however if I wish to talk I need to press the microphone - this stops 2 way chat until microphone is turned off. Also altering the microphone in smart things made no difference to the ring app itself when launched. I have tried turning off Bluetooth as previously suggested this did work but intermittently. Pretty poor show from ring

(My Englisch very bad)

My solution:

I take the audiofunction from my galaxy gear s3 off, then i have sound out of the both speaker and when i take the audiofunction on then came the Sound out of the top speaker.