Ring app requires 'Force Quit' macOS Big Sur 11

The Ring app on macOS Big Sur 11.xxx will not quit. Shows ‘unresponsive’ and of course prevents the computer from sleeping or shutting down. A manual ‘Force Quit’ is required.

This is not new nor unique to Big Sur. I see references to identical behavior going back at least a year. Started this topic because the specific behavior was not identified in any Subject explicitly and specifically.

The Ring app has been a disappointment generally compared to expectations from presumably a well-financed parent. As is corporate communications behavior. For example, I was unable to find a way to report (email) this information except to join these forums and comment here. Never thought anyone could ‘out Verizon Verizon’, but apparently I was wrong.

3 Likes

Same problem here. I opens and seems to work fine, but when I try to close it, it freezes and I have to Force Close the app. Please help.

Same problem here. I opens and seems to work fine, but when I try to close it, it freezes and I have to Force Close the app. Please help.

Hi neighbors! Try uninstalling the Ring App, restarting your Mac device, and reinstalling the Ring App. This typically resolves app performance concerns. Additionally, make sure all of the updates on your Mac device were properly installed.

Nope. Didn’t think that would work. Check the reviews at the Apple App store. I’m sticking with Ring because I don’t know of a better alternative. But I’m also not expanding the ‘network’. Ring needs to get as interested in a quality product (read decent app) as they obviously are in selling devices. Unless that happens there will be a mass exodus soon as someone offers an alternative.

FYI all, just spoke to “community” rep on Ring phone line and, to my amazement, he said the company had decided simply not to support/upgrade the app for desktop or laptop use from here on out… as a means, he said, of getting people to use mobile devices.

So much for consumer service…

1 Like

Interestingly enough, Logitech used the same approach for their hub-based remotes starting with no spport for Catalina. Once Apple went wit ha 64bit system, Logitech figuers it’s too much work to support desktop applications going forward.

Very dissappointing!

I have the same issue.

On my Mac all day long and need the app there, rather than on my device.

I continually needs a Force Quit as it continually stops working.

And there’s no fix?

Sucks.

2 Likes

Are Ring serious about supporting their macOS users? I’ve. been getting this error with the macOS Ring App version 2.8.2, will Ring get behind their macOS users and update their Ring App to be compatible with macOS Big Sur? It’s not very good to have no way of reporting this problem to the software developers. I think you’ll lose lots of new customers after they realise you’re not really interested in giving them support.

I think the answer to support for macOS is NO. To add the latest I’ve been unable to change the email on the account. It’s ‘grayed out’ as a choice with a browser login; not available as a choice on the Mac App; and fails with the iPhone.

Did some searching for alternatives and found at least one other brand (forget which now) with a user comment that they also support nothing but ‘mobile’ devices.

I did go on the Apple App Store and left negative feed back for the App reference the lack of functionality and support.

Oh yeah. Have not been monitoring the cameras much over the holidays (Christmas lights got hung in such a way that main camera was useless LOL). But as of today guess what? Yep. macOS app hung and had to force quit.

I’m not impressed. At all. When I find an alternative - gone.

It’s not just Big Sur. Same thing happening with Mojave 10.14.6

Ring 2.8.2 also hangs with High Sierra, MacOS 10.13.6

I use both Mac and mobile but I want to use Mac on a daily basis not mobile come on Ring fix this problem or I will have to change which cameras I use

The Mac OS Ring app has never worked well for me. I wish it would as I am on my computer all day for work and would love to monitor my cameras from my desktop.

The app will not “quit” normally and must be force quit EVERY TIME. Not sure why this bug (which has been there as long as I can remember) has not been fixed as a priority. It causes all sorts of sleeping and power management issues becaus it keep hanging around until you force quit the app every time. No amount of reboots reinstalls or other nonsense fixes the issue.

OS 10.14.6 iMac 27" 2019

1 Like

You got that right. Ring app crashes on Catalina regularly. I might as well close ring every time I close the lid on my MBP, then re-start it.

Ring apparently has no support for app tech issues, other than this community BB. Better off just using Google to search for your issue.

I found a suggestion online to delete the Ring app, reboot, then download and re-install Ring. That has not solved the problem.

That makes me very sorry I got Ring devices.

Still angry? App still hanging on quitting? Try this:

  1. Delete the app.

  2. Look for a folder called com.ring.mac, and delete it with extreme prejudice.

  3. Also look for the folder called com.ring.mac, and delete that little SOB too.

  4. Just to be thorough, and because your left-over garbage installation cruft from ancient versions of Ring may be different than mine, look for other things that look like they belong to ring, and delete them too. It’s a little scary, but satisfying.

I don’t remember where I found those folders, but you can search, because you are smarter than a Ring support person. They are likely in ~/Library/Application Support, or ~/Library/Preferences. Those folders made you angry by breaking the app, so you should enjoy hunting them down in /Library and ~/Library, and killing them. Note of caution, something called “com.apple.boringfile” (and the like) isn’t your enemy. Something that looks like “com.ring.support.h8s.u” is the enemy. (look for the obvious word “ring” in the name).

Then install the latest version of the Ring App. I have 2.8.3, which didn’t work before I got murderous on the folders shown above.

If your system is like mine, the Ring App will work. If it doesn’t, well, I tried to help.

Also, Ring support should be ashamed of itself for not knowing about this. Get in the sea, guys.

2 Likes

2.8.3 still has the same Force Quit problems for me. I uninstalled and use an app cleaner to delete all the folders for the Ring App and reinstalled. No joy, same problem.

I’ve canceled my subscription until they fix it. I’ve also left a bad review on the Apple App Store (there are many bad reviews all citing the same problem. Going to leave some bad reviews on Amazon as well. What an absolute disappointment.

Mac Big Sur use 2.8.1 for better (not great) ring! tried 2.8.3 it still sucks!!

For what it’s worth, whatever I did (https://community.ring.com/t/ring-app-requires-force-quit-macos-big-sur-11/19735/17?u=futureformercustomer) is working on my Mac at MacOS 11.4 with Ring 2.8.3. ¯_(ツ)_/¯ I’m sorry that you’re still having problems with it. My only other suggestion would be to manually go through the filesystem in the locations I mentioned and see if the app cleaner missed something. I’m an old Unix guy and I don’t quite trust app cleaners. Good luck to you.