Ring app, IOS, continue "button" doesn't work

New iPhone 15 Pro, worked on iPhone 11. I enter user name email address, but the continue “button” is just text and I can’t get to the password entry. Deleted and reinstalled the app. No VPN. I can log in via browser. Can’t do anything with doorbell camera. Been working for couple of years on the old iPhone. Phone and ring app updated.

1 Like

I have the same issue. Iphone 13 pro IOS 17.2.1
uninstalled the Ring app and reinstalled it.
Rebooted Iphone a few times.
Continue button after specifying email is not active.
Cannot login.
Can login to the Ring using the browser on laptop etc.

1 Like

My wife’s phone works. It has a fairly new ios updated 2 weeks ago.
I deleted all ring app data , also deleted the saved password in iphone.
Still no luck.
Has to be a bug in the app.
Don’t have VPN.

1 Like

Well, worst case, it saves me $40 a year. Not that great a device anyway, too much delay in notification.

Hi neighbors. Thank you for sharing your concern. Rest assured that our team is investigating and working to resolve the issue as soon as possible. In the meantime, as a temporary workaround, you can use Ring.com on your phone’s web browser to log in and view your Ring devices. Once I receive an update regarding this concern, I will make sure to post it here. Thank you for your time and patience.

Hi, I cannot long into the app, iOS version but I can long in via any browsers. Have disabled all VPNs and all apps and software are up to date. Any help would be appreciated

1 Like

Logging in on my phone’s browser, Duck Duck Go, did not work either.

Any update to this? I have the same issue. New phone, iPhone 15 pro max. Insane to pay a yearly subscription and not have app access.

1 Like

No point in keeping the account, I don’t see any sign they are going to fix it. Save me a few bucks anyway.

I have the same issue. My iOS software is up to date. I have the latest Ring app, version 5.68. At the sign in screen, I can enter my email address but there is no button to continue. The word “Continue” is floating in white space in ordinary Times New Roman font, and it is not clickable.

Meanwhile I can log in through a Chrome browser either on my phone or on my desktop. But the Chrome browser doesn’t alert me if someone rings my doorbell and I’m not at home. That alert should be happening through the Ring app, and I can’t log in.

Welcome to the “ring won’t connect” club. We get together on the third Monday of the month and swear at them.

Hi Ring,

I want to raise a complaint! Continue button is deactivated, so i cannot log into app. Please refund every day that this is an issue! Please respond to my personal email of how you are addressing this issue and how you are going to issue the refund. Please do not fob me off with use website. I want to use app and a refund of money is the only compensation i am interested in as you are not providing the service i am paying for!!! Please treat this as a complaint and forward your complaints procedure to my personal email address.

Same problem with my iPhone after updating iOS. was working fine. None of Ring’s suggestions help. No VPN. Laptop works but what’s the point? Needs to work on my phone so I can talk to people at the door!

Hi Neighbors. I’ve marked this post as the solution to let others know that we are actively looking into this issue. We understand the frustration this must cause, but rest assured, we are working to fix this. Thank you for your patience.

Interesting “solution”

Attn Ring - stop marking this post resolved. We can all log onto our web browser and open our cameras there, but there’s no push notifications, immediate access to the cameras, and we can’t control anything with the browser. Why am I paying a subscription to something I can’t use??? Also how long does it take your developers to fix a button?

This “solution” is not. I need to setup a new sensor. I can’t do it with the browser.
This is a critical bug. Your developers need to fix it within hours and it has been several weeks.
Please get on with it.

Hi Neighbors. Please see the response to understand why the post is marked with a solution.

Same issue! I was prompted by ring to update the app…and I did. :frowning: now my &@$#% continue button is not active and I can’t use the app! And using the website does not push notifications to my watch or phone! Please do something!!!

Hey neighbors, thank you for your continued feedback. Our team has investigated this issue and found that it is caused by having JavaScript disabled, or having Cookies blocked. Our team is working on updating the troubleshooting documentation to reflect this information.

On iOS, open ‘Settings’ → ‘Safari’ → Scroll all the way down to ‘Advanced’ → Verify that the ‘JavaScript’ toggle is enabled. The toggle will appear green if enabled, and grey if disabled. Check the Cookie settings to make sure these are not blocked as well. After adjusting these settings, force close the Ring app and attempt to log in again.