Ring App for Mac - Invalid Credentials

Hi All,

I’m suddenly unable to login to the Ring app for Mac. I receive an “Invalid credentials.” error message. I’m able to use the same email/password to log into the ring.com website. I copy and paste the credentials from a text pad so I know I’m using the exact same email/password for the mac app and website. Does anyone else have this issue? I’m running Ring app version 2.4.2 (747) and my Mac is running Catalina version 10.15.3.

Thanks!

Dave

Sorry to hear about this experience @dave311! It definitely sounds like you are using the correct credentials. I recommend removing and reinstalling the Ring app, as well as check that any VPN or VPN related tool/ app is disabled and closed.

Feel free to keep us updated on your results! :slight_smile:

Thanks Marley, I uninstalled, rebooted and reinstalled and I’m still receiving Invalid Credentials when attempting to log in via Ring App for Mac. Logging into ring.com website, as well as, the community.ring.com site is successful. VPN is not running on my computer. I also temporarily disabled my firewall but no luck. I’m out of ideas aside. Let me know if you have anything else I can try. Thanks! Dave

I’m not certain what changed but today I was able to login via the Mac App. All good now!

@Marley_Ring wrote:

Sorry to hear about this experience @dave311! It definitely sounds like you are using the correct credentials. I recommend removing and reinstalling the Ring app, as well as check that any VPN or VPN related tool/ app is disabled and closed.

Feel free to keep us updated on your results! :slight_smile:

1 Like

Same issue, correct credential but failed to log into the app.

Website works good.

Hey @wangtuobin. I recommend removing the Ring app from your Mac computer, restarting your computer and then reinstalling the Ring app from your Mac to see if this helps. In addition, please ensure you have no VPNs turned on or any VPN related tool enabled when accessing the Ring app on your Mac.