Ring app for Android continuously crashing

The past few days, the Ring app crashes when I attempt to open it from the icon on my windows phone. It will show the blue Ring homescreen, then fail out. I get an Android message saying “Ring app keeps stopping.” I have already deleted the app, restarted my phone, and reinstalled the app from the Google Playstore. It worked ok for a little while, but now it is crashing again. I still am getting some live notifications. I can usually open the live video from a motion notification, but nothing else associated with the app works.

Hey @PaveSpike. What kind of phone do you have, as well as what OS is the phone running? In addition, what version of the Ring app do you have installed?

Chelsea,

The phone is a Moto x4, running android version 9.

Current version: PPWS29.69-39-6-10

Security updated July 1, 2020

Ring app version is whatever is current in the Google Play store… I have uninstalled and reinstalled from the Play store 3 times now. “3.29.0” is what Play store says.

After installing the app, logging in, and being able to see my cameras, any attempt to open the app after that results in a crash.

Have you removed the app restarted the phone and then reinstalled the app?
Also, do you have decent space available on your internal storage?
Did it work on the previous version of the app?

I have been a Ring user for almost 2 years with this device, no issues before now.

I have removed app, restarted phone, and reinstalled app from Play store at least 3 times now.

Internal storage of phone is 32GB. It was up around 96% used when this started happening. I today installed a new micro SD card for additional memory and moved several gig of data to it. Internal storage is now down to 72% used, or 8GB available. Surely this must be enough for the app. I have restarted multiple times to ensure the device and apps recognize this. The latest install of Ring app sadly crashes still. This is about the 4th install I have tried.

Was Ring app recently updated that may have caused this issue?

There was a recent update. That may be the issue. I was a motoxprt on Motorola support forum for 10 years. I remember the X4 very well. It was a very stable phone. 8 gigs should be fine. Make sure you don’t move the Ring app to the SD card. That could cause issues.
You could try an older version to see if it was the update that caused the issue. Then we can let Ring know that. I will see if I can get a link for the last version on apk mirror’s site.

1 Like

I found version 3.28.1 which was the last version. You can download it here.
https://www.apkmirror.com/apk/ring-com/ring-always-home/ring-always-home-3-28-1-release/ring-always-home-3-28-1-android-apk-download/
Remember to remove the version you have now before installing this one. The site is safe and I’ve been using it for many years.
If it works and is stable. Then we know it’s the update and then inform Ring of the app’s issue with the model.
Let me know what happens.

2 Likes

Eagle328, thank you very much for your help and insight.
Preliminary results: I uninstalled the current Ring app, did 2 restarts on my phone, then downloaded the previous Ring app version that you linked me to. In the first few minutes of using it, I can open and close the app numerous times, at-will, with no crashes or other errors. So it appears to be working.
Of course, I’d like ring to look at this further to resolve this with the current version, AND my question for you is what will prevent my device from automatically trying to update the app if/when it sees I have the old version running? Can I keep this older stable version running?

1 Like

Good to hear it’s the app and not your phone. I would turn off automatic updates in the play store. This will prevent it from doing it in its own. I’ve learned after many years of Android that turning it off is the best. This way you know what updates. Then if something goes wrong you can remember that it was just updated and it’s most likely the cause of any new issues.

I will bring this thread to Ring’s attention. They should respond and hopefully pass this problem to the right team to correct the issue you’re experiencing. At least for now it all works and you’re not missing anything being one update behind.

1 Like

I have the same issues since last week. Submitted zillion feedbacks no answer yet. Bummer

Eagle328, thank you for all of your help. The old version you linked me to has been working all weekend through today. I will keep it for the forseeable future.

1 Like

Glad to hear it’s working. I reached out to Ring but haven’t heard back. I think they may be off work. But do keep that version until another update comes out for sure.

1 Like

I just received an update on the Ring app this afternoon to 3.29.1. This might fix your issue if you wanted to try. just wanted to let you know.

1 Like

Hey neighbors! Thank you for bringing up this concern and working through it to find a temporary resolution. Rest assured I have passed on the information received in this forum and from @Eagle328 onto the appropriate teams while this look into this, but would really appreciate if you could take a look at the new app version as @Eagle328 has mentioned and let me know if the app has the same crashing behavior. Thank you in advance! :smiley_cat:

is anyone having this issue today? mine has been working perfectly since we installed it last weekend, then mid morning today it has crashed every time i have tried to open the app.

i have uninstalled and reinstalled the app and i have restarted my phone but no luck

Same thing. The app will crash beforei can actually exit it. And notifications are seriously delyed are dont come at all