Ring app 5.59 on IOS, Snooze icon missing, last Health check on 1969-12-31

Good day all,

Since updating to 5.59 yesterday I can no longer snooze my alarms (moon icon, that was in the top right on the main page is no longer there) and the health check reports it was last run in 1969-12-31 or just before the epoch…

The health check date I’m not too concerned about and has already been reported here.

Not being able to snooze the alarms for the other 3 people that live here and are shift workers is an issue for our 24hr a day home. Maybe the feature has moved to a different location in the app and I’m not picking up on it but it seems to now be absent.

Neither of these issues are present in the previous version of the app which I’ve advised everyone else in the house to say on for the time being but given it’s mostly me leaving while they sleep it’s not much help.

I’m hopeful that the feature has moved to another location and I’m just overlooking it but if not, please bring it back.

While I’m here, I’d like to add that icon badge counts in IOS would be nice. I see that they work for droids but are oddly omitted from IOS for some reason.

Thanks for reading.

Hi @Looking2See. Thanks for this information. Can you share a screenshot of your Dashboard so we can see what it looks like without the Snooze Icon?

As for the date of 1969, this is just a visual bug that will be corrected with the next app update.

Thank you for the response and sorry for the delay in getting back to you.

The image on the left (white) is from 5.58, the image on the right (black) is from 5.59.

RE: The health check date, it does display the correct date when viewed via browser.

Hi @Looking2See. Thank you for sharing those screenshots. If you turn off Dark Mode, do you see the Global Snooze icon, or is it still missing?

Hi @Caitlyn_Ring, no it does not change, I’ve tried Auto, Always Light, Always Dark including Standard and Extra Dark. I also tried mashing fingers in the spot that did once contain that lovely sleep enabling snooze button but to no avail.

FYI, those are shots from two different phones, my SOs in white and mine in black.

I’ve since updated to 5.59 on their phone (the white one) and the Snooze icon is now missing from it as well. I did verify that it was there and working perfectly just prior to updating the Ring app exclusively a few moments ago.

Any suggestions welcomed and thank you for the response.

@Looking2See Thanks for that confirmation. I do not have any suggestions at this time, but I have already shared this thread with my teams to let them know about this issue. I know it’s inconvenient not having access to this feature in the meantime, but we will share any applicable updates once we have more information.