Ring App 5.48.0

Same problem here, all my cameras show 9+ new events but I have viewed them all. My wife has not updated her app to the latest version and not an issue for her. I have reinstalled app/logged out etc so it appears a fix is needed.


Bil -

Although I like your overall concept, I suspect that urging users to individually call Ring Support would probably not have the desired effect in this situation. There is simply too little visibility/accountability.

A much quicker (and hopefully, better) strategy might be to have as many users as possible create a post in this thread. Doing so would seemingly provide a more obvious/tangible “voice” for users who are being negatively impacted.

If Ring Community members began to act in a more cohesive manner, one would hope that it would encourage Ring to give higher priority to Quality Assurance testing and bug fixes – instead of constantly focusing on Marketing/Sales.


Frustrated 427 -

Definitely makes sense. Let’s hope the Ring community steps up and Ring improves their testing/quality assurance before releasing their app updates.

1 Like

i’ve logged out and back in, logged out and deleted app and reinstalled and logged back in, deleted all events and all snapshots, it says footage has been deleted but still shows 9+ on camera badge. this speaks loudly and poorly for any level of quality control and makes be very worried about the security of the overall system.

1 Like

I can’t get rid of the red notifications icon

1 Like

Blue circled notifications do not go away even after viewing all of them. Before the update, the red circles used to go away once all the notifications were viewed.

Any help or assistance on this matter will be appreciated.

1 Like

Same with mine after doing the update on iOS

1 Like

Same issue here, on 2 iPhones. Awaiting a fix.

1 Like

I can’t measure how much time I’ve wasted on this bug. It first showed up on a new iPhone for my wife (who complained to me about this issue) and I tried everything you can possibly think of trying - and nothing worked on her phone - yet my phone and also my iPad worked fine. Then this morning I discovered that her phone was on app version 5.48.0 and my phone and iPad were still on 5.47.0. Stupidly I updated my phone to 5.48.0 and now I have exactly the same problem that my wife (and everyone else in this topic) has. At least I now know this is not a problem with her phone (nor is it a problem with my phone) - it’s a problem with app version 5.48.0. Come on Ring - get a fix for this - or make 5.47.0 available again (even if you have to post it as a new version while you do the work to fix this issue).

5.48.2 looks like it has finally fixed this problem. it was a frustrating few days but looks like it’s resolved now. thanks to ring for getting this fixed.


I can confirm, version 548.2 has been release , the bug has been fixed.


I also can confirm that 5.48.2 fixed the two devices that I had on 5.48.0. I happened to read many of the recent ratings on the app store that were complaining about the issue - virtually all of the reviews were one or two stars - all because of this problem. This may have motivated the developers to get a fix out there.


I hope it motivates developers to be more conscientious and thoroughly check for bugs especially one as noticeable as this one, before releasing a new build. There’s no excuse for this! Carelessness! This company goes through phases of this type of performance!

1 Like

Unfortunately, I still have number badges displayed on the “What’s New” and
“Shop Deals” menu titles in the Ring app menu. Has anyone figured out how to turn off the display of the number badges without viewing any marketing/advertising screens?

Obviously, it makes no sense to “click through” all the marketing/advertising screens to (temporarily) turn off the display of the associated number badges. Rewarding Ring (and its parent company) for abusive, anti-consumer tactics just harms all Ring users.


Try the suggestion in this post:

Chelsea_Ring posted:

Hey neighbors! We’ve implemented a new aspect to this section of the Ring app to address this concern. If your New Features notifications won’t go away, you can can manually clear it in the Ring app. Tap on What’s New and then tap the icon with a check mark in it on the top right.

You’ll have to mark all items as seen to complete the process.

1 Like


Thanks for the suggestion.

Unfortunately, the effects of selecting the Checkmark icon seem to be temporary in nature. Thus, presumably, it’s just a matter of time before the number icon reappears on the “What’s New” menu title.

Frustrated427 -
Yes, it is temporary - at least to an extent. If there are new features that show up (and put a red dot on the Dashboard “hamburger”) then this clears them - at that point in time. But if there are new “New Features” added in the future they will show up as new - and require marking them as seen - again. It seems that the way this works is that it doesn’t prevent notification of future new features - it only allows you to acknowledge that you have seen the new features at a point in time and clear the notification.

1 Like

Wow - I spent most of this afternoon looking to see if anyone (else) had experienced this problem and didn’t remember you mentioning it.

I can confirm that (at least for me) this problem still exists in 5.48.2 – though they did fix the badge issue from 5.48.0 - it seems like they overlooked this issue. I have found that selecting any recorded event by clicking on the “History” tile at the top of the dashboard and deleting it will not delete the event you selected - it will delete some other event - sometimes above, sometimes below, sometimes randomly located in the history but almost never the event you actually wanted to delete. NOT GOOD!

A workaround to this is that if you select the device that generated a video you want to delete, and in the settings for that device select the “Event History” for that device, you can delete the correct recording as that function works correctly. I have spent some time this afternoon with Tech Support and they are now aware of this issue.

Are the Ring systems linked to Amazon !!! Ring2 for years had no issues. The system woul verbally from iPhone would announce every time a human, animal, and even a cockroach at 130am . The cockroach was on the camera lens. Able to see from iPhone and was relieved. I do not hear any notifications! Between Xmas and New Year’s Eve it has not worked like it used to I asked if I had to link to Amazon to have my doorbell alert me, response “NO” linking to Amazon should not effect service. I have yet to return to the excellent service I had with Ring I bragged about how secure the Ring service was. Amazon has ruined this company…

My system is not linked to Amazon and has been working well for over a year. I do have an Echo Show with the Ring skill installed and it works great at showing me activity, and as I haven’t been traveling this past year I did not have alerts to my phone turned on but did use my phone to review events.

I started having a problem with the light on my Floodlight Cam coming on - to the extent that my neighbors were complaining though, and in working on solving that I updated to ring version 5.48.0 and got the badge issue, which was fixed by 5.48.2. But apparently the issue with deleting the wrong file (in my case not the file I selected to delete but rather some other event - but never the one I selected) may have started with 5.48.0 (as you reported it) and was not fixed in 5.48.2 which I think was just a bug fix for the badge issue. But it needs another bug fix - in my case I didn’t lose any history that was important but if I lost critical events I’d be much more upset than I am.