Ring Android App is Now a Complete Mess

For the past 2 months or so, the Ring app for Android keeps taking forever to open when I get a motion notification. Sometimes, it works just fine when I tap the notification. Live View also takes a long time to open.

I’ve cleared the app cache and data, also removed the app and reinstalled it. None of this has helped. My wife is also having the same issue on her Android. We both have Samsung S10 Plus running Android 10 (This was happening prior to upgrading to Android 10). Ring app version: 3.21.1.

Fyi, lots of people are reporting similar issues in the Google Playstore reviews.

My ask: Is Ring aware of all these issues, and what could’ve changed to triggers this?

2 Likes

I’m having the same issue on Samsung Note 10+ and it’s been defective for several weeks now. When is Ring going to address these issues? Both my ring devices are useless to me if I don’t get notifications and I can’t use Live View.

2 Likes
  • Bump, same here… Missed two rings on my doorbell today, the first notification came up quick enough, but when I pressed it, it went away, and the app did not open! Had to find the app, open it and by then the parcel guy was gone.

Second time, I first received the notification several minutes later, even though I’ve disabled battery saving for the app. (My wife got the ring timely enough on her iPhone)

Phone is Samsung S10E

Completely agree. The app has become a complete and utter joke. I can’t view motion detection takes forever to load. Live view just freezes the app and I have to force close the app. I tried Ring support and their answer was to use Rapid Ring which isn’t an option for me as I’m disabled and i have the ring linked to my smart lock so I can unlock the door if I need to when viewing the camera. This feature isn’t available on rapid Ring.

Same for me. Samsung S10 plus and the RING app hasn’t worked in weeks/month at least. I go to look at a live view and it freezes and i can’t see anything.

I mean if the APP doesn’t work then the Ring service is esentially worthless. If not fixed by the end of the month probably going to remove RING and go with NEST or ADT for video doorbell.

Try resetting your network in your phone settings. Make sure you know how to reconnect any wifi connections since you will need to reconnect after the reset. Someone posted that this fixed there issue already.

i did more digging and foudn out its because I have a Samsung Galaxy Watch and the bluetooth on. Once I turned off the bluetooth the RING APP worked. Its a glitch RING has to fix in their App.

3 Likes

All, I think I have discovered the fix on my phone, though it is not ideal. I hope it works for you.

I did some heavy diagnosing around the data saver feature on my new Galaxy S10 to see if Ring was having issues with it. I discovered that while in data saver mode, even though I took several exceptions to Ring for data saver, I could not access the live feed. I figured maybe there was some tie to some other app or system app, so I tried taking exception to EVERY app on my phone while in data saver mode, but Ring would still not show my live feed. It’s only when I turn the main switch off to data saver mode that Ring will show my live feed. It makes no sense, but it works. So try that and let me know if this fixed it for you, too!

This actually works when I turned off bluetooth on my samsung watch my ring actually loaded the video. I;ve had problems loading the video for a month or two but now its starting to work. Thank you so much for your help!

1 Like

SyrMike2,

Thanks for the suggestion. I tried turning just my bluetooth off and the app seems to be working as it should. I still need to test the app with motion notification to see if that works as well. If it’s a bug - as you said, Ring should be working on that to fix it ASAP. Let’s hope they’re aware of that.

Wife and I were having the same issue and once we disconnected Bluetooth the live feed started working again. Thanks for the tip.

Very hit and miss. the only thing that it works on is my Mac to tell me there is a motion at the door. I really need it for my mobile for when I am out. Sometimes works (about three times) other than that, just get continuous circle. Only just got it back on mobile after starting right from begining again. Ridiculous as you can get the some sort of thing now for under £50 which is not as much to lose if it refuses to work. A lot of money going into someones pockets.

I read this after finding our the fix for myself eventually for my S10. I never used to have a problem activating live video on Ring app with Data Saver on but it definitely was the problem after trying loads of fixes. Despite my settings allowing the app whilst Data Saver is on, it does not work.

I have new functions on the Ring app so can only assume these updates have impacted in this way.

I turned off my bluetooth to disconnect the watch and it loaded. This will get very annoying very quickly. Ring please fix this issue ASAP.

1 Like