Ring Alarm Won't Stay In Away Mode!

Can someone PLEASE help me? My Ring Alarm no longer stays in Away Mode. After the exit countdown, it automatically switches the alarm to Home Mode. We’ve tried using the keypad and the app, but haven’t had any success. According to the device history, the problem started on September 30. Before that, it worked perfectly.

Have you tried Rebooting your Base Station?
Ring App - Hamburger Menu - Devices - Alarm Base Station - Base Station - Device Settings - Advanced Options - Reboot Base Station

Thank you for the response. Yes I did, and just rebooted it again, but it still isn’t working properly.

If no one else has any suggestions, you’ll need to reach out to Ring Support.
Contact Us – Ring Help

I truly appreciate your suggestion. I will contact Ring Support. Thank you.

userwb1508 -

Which method are you using to switch to Away mode?

  • Ring keypad
  • Ring app
  • Alexa

I’ve tried it with the Ring keypad and the Ring app.

userwb1508 -

That’s interesting. (I thought you might say that you were using Alexa to switch to Away mode – but apparently, that’s not the case.)

Do you have only one Ring Keypad? If so, is it a 1st Gen or 2nd Gen device?

In the Event History list for the Base Station… exactly what does it say for each status from the time you use your Ring Keypad to change the Ring Alarm status to “Away mode” to the time it is automatically changed to “Home Mode”? For example does it say:

  • Start exit delay
  • Changed to Away mode from Keypad by (user name)
  • Changed to Home mode by xxxx

(Hopefully, the last bullet listed above will indicate exactly what is causing the problem.)

Hi @userwb1508. This is interesting. Would you be able to share a screen recording of the Ring app while this happens? I can then share it with my team for some insight and see if we can get to the bottom of this!