Ring Alarm stuck on update

My Ring app still shows my base is still trying to update 8 hours later. Should I unplug the base and remove the batteries? I noticed it when I woke up this morning so could have been longer than 8 hours. It’s on wifi. Thanks.


Hi @xNitetime, were you able to get it out of updating? If so, please share what you did to help other neighbors who might be experiencing this. The Alarm Base Station can also be plugged in via Ethernet, so you can always attempt to do that and see if it speeds up the update. If the Base Station is still updating after that, please reach out to our support team at 1-800-656-1918!

I ended up unplugging the base power and removed the battery. Then added the battery back and plugged it back in which seemed to work. In the app showed everything was updated.

1 Like

Thanks! Mine is doing the exact same thing. Must be a bug with the latest update

I had the same issue. I unplugged it and plugged it back in and all I got was an amber power light. Nothing else came on. Did a factory reset and now the app is still showing updating but the base unit is in setup mode. Anyone know how to get the app to stop the update process? When logging into the website, it also shows that the base unit is updating.

I am having same issue.

Same here. I’m beginning to think that the Ring alarms aren’t very good.

My issue appeared to be the same, stuck on an update but actually was an issue with the Android app.

Cleared the storage cache for the Ring app and the updating status went away. In part figured this out when I looked on my iPad and the Alarm had finished the update but my Android phone still showed updating…30 minutes later.

1 Like

My solution was to hard wire the alarm to the router vs trying to do it wireless. After the update was done and all sensors online, I switched to wireless with no issues. I had to do a full factory reset of the base before plugging it in to the router.

Same issue with my hard wired unit. Unplugging the power and removing the battery , waiting 60 seconds, then adding the battery and plugging the power returned the unit to normal operating condition. It then began the update again which completed successfully after 2-3 mins. I suspect the unit may have gotten confused by hiccups at the home network or ISP level, a common problem with network equipment often resolve by a simple restart.

1 Like

I have same issue …it says “ring base station is updating”. It doesn’t”t give me option to disarm.

I can see so many users posted same issue but ring doesn’t care to fix the issue

Not many have any issue. This is a support forum. So, not many come here to say everything is great…
Call customer service.
They can help you just like all the others. I’m sure they all had the same answer too.

Hey neighbors! If you find yourself having this concern, the best first step is to reach out to our support team here. They will be able to diagnose your Base Station quickly and efficiently to get it back up and running in no time so you can feel safe and secure. Additionally, another neighbor shared that when they unplugged the Base Station from power, removed the battery, waited a bit, added the battery back in and plugged it back up, it seemed to work! Feel free to give this a try as well if you wish to. I will be marking this post as a solution going forward to ensure that all neighbors are getting a speedy resolution for their concern.


Mine has been updating for 12hrs and Is still going. The contact centre is CLOSED until tomorrow, absolute garbage. If there’s an update staff should be on standby for issues such as this.

I know this is a little late to reply to this thread, but I just purchased my alarm (Received it yesterday 9/1/2020) and I ran into this same issue.

What solved my issue was connecting the base station via an ethernet connection temporarily. After sitting there for an hour and a half watching my ring app state “Updating” I went to the internet to see if others were having this issue and I found this thread. I attempted the “solution” steps listed, but those did not work for me.

So upon further inspection of my base station, I noticed the internet LED on the back of the base station was not solid green as it should be. So I figured there might be an issue setting up the base station on wifi at the start. I then decided to connect my base station via ethernet and not ten seconds later the internet LED turned green and two minutes later everything was updated. Ok great, right? Not so much, because there is one additional step you have to do after you disconnect your base station from ethernet and that is to actually assign the connection back to WiFi (It will not automatically swap back to it if it loses the ethernet connection). Once I swapped my base station back to WiFi in the Ring app, I was in the clear. I hope this helps.

1 Like