Ring Alarm Pro Base - Solid Red Power Light

Hi - been a Ring user for a few years. Decided to upgrade to Pro base - primarily for edge video processing. I may assess the Eero; but have a pretty solid network using Unifi with 60+ devices so unsure if I want to make that leap.

In any event - received new base - opened it up and found the power LED (lightning bolt) is solid red. I can remove the battery and keep it plugged in. Same problem. No other LEDs. The ring on front does not light up. I know AWS was having major issues today; but this appears to be a hardware issue and I am unable to swap the existing base with the pro base (through the Ring App). It doesn’t even see the Pro base via bluetooth.

Thoughts? I’ve tried to reset, etc. but suspect it is a bad module.

Hi @Mutchinator. For this concern, I’d definitely recommend touching base with our support team if you haven’t already. Please give our support team a call at one of the numbers available here so they can walk through any applicable troubleshooting steps with you in order to get your Base Station up and running. If you are outside of the US, please visit here to see how to contact support.

I have this same issue (solid red lightning bolt) with my new Ring Alarm Pro. Tried a reset and it wouldn’t go off of the solid red. Ring is replacing the unit for me. Super annoying to have to reconnect it with all of my cameras, lights, etc. which are all already installed and require ladders to get to.

Yes I replaced it and what a pain to reset and sync them …