Ring alarm - keypads non responsive when alarm triggers

I setup a ring alarm about two months ago with following devices:

  • 3 keypads (plugged in all the time)
  • 24 contact sensors
  • 5 motions
  • 4 glass break sensors
  • 3 dome alarm sirens
  • 3 signal extenders
  • 1 base station (tried both wired and wireless)

System appears to work fine except when an alarm triggers. Almost every single time (99% of the time) alarm triggers, all keypads + dome sirens start sounding alarm as expected. But when I try to disarm using any keypad, it does not work! Keypads have red lights blinking with siren. Entering disarm code has no effect on any of the 3 keypads! (not a battery issue as all keypads are plugged in).

When I try to disarm using the Ring app, it disarms the system right away and base station stops the siren but all keypads + dome siren keep ringing. This probably means that keypads for some reason lose communication with the system when the alarm triggers. I even took keypads close to the base station, about a foot away and tried to disarm, and still didn’t work!

This is super frustrating and every time alarm triggers, I have to run around the house to reset each keypad for them to stop the siren and remove batteries from dome siren. Even after reset, they start sounding and I have to reset them completely and re-add them.

All 3 keypads are about 20-25 feet away from the base station so I doubt it’s a signal issue but who knows as all 3 keypads blink red signal icons occasionally which I find very odd.

Also, I am puzzled that when alarm triggers, all three keypads receive signal to start the siren but when it comes time to disarm, they no longer communicate with the base station. Doesn’t make sense at all.

I am considering ripping out the Ring system and going back to my traditional system as this is super annoying and frustrating. Any idea or suggestion would be greatly appreciated. Please help!

Hi, I am 100% sure the code is correct as I am able to arm successfully using the keypad using the same code. I called support twice and they just had me reset the keypad which is completely useless. I am going to have to demand to talk to tier 2 support.

Hi @dakster. A few things to cover here. First, I would try bringing the Keypad next to the Base Station and then arming/disarming your Ring Alarm system. Next, repeat this where the Keypad is normally located. Do they both work when you put in the code, then select Disarm mode? Next, are there any other electrical devices in close proximity to your Keypads? It is possible there is some sort of interference. This post here has some information about this. If you contact our support team again, definitely ask for our level 2 support team, since you’ve called about this issue before.

Hi @Tom_Ring, this issue always occurs when the alarm triggers and I try to disarm. I had already tried bringing all 3 keypads within 2 feet of the base station and it still wouldn’t disarm, which I found very very odd.

I did talk to level 2 tech and he said he is seeing some interference on Ch2 and he was running some script to make things better. I haven’t had a chance to test this again, but later today, I plan to trigger the alarm and see if I am able to disarm successfully.

I do have ubiquiti access points but they use 2.4 and 5ghz which I am not sure would interfere with zwave which runs around 900mhz. I also have samsung smartthings hub (zwave) but that’s about 20 ft away from Ring base station.

watch this video, the problem I am having is supper annoying and frustrating!!

Hi @dakster. Thank you for sharing the video. That is very odd. I would continue to work with our level 2 Ring Alarm support team to get this fixed.

Hey @dakster! I just wanted to touch base with you here and see if you were able to get this resolved with our support team, and what that resolution entailed? If you are still unable to find a resolution, would be happy to look into this further, and inquire also how these keypads behave if your Samsung SmartThings hub was turned off (as this may be causing interference). Let us know!

2 Likes