Ring Alarm Base Station Not going in pairing mode

Clicking on the pairing button makes the blue led lights just blink slowly and not spin. Clicking Find my base station doesn’t pair the to the base station.

Hi @vkshah, have you reached out to our support team yet for this? This is a great place to start if the Base Station is not spinning as intended when going through setup. Please let us know what they were able to do to help resolve your concern!

2 Likes

does maine station light stay on all the time

This is fixed now. Thanks all.

How did you solve the issue ? Im having the same problem.

1 Like

I am also having this issue. Doing everything the Help articles say to do.

I did a hard reset and waited for some time before trying it again. It worked then.

1 Like

Similar issue except ring doesn’t spin at all. Your tech support is unavailable.

1 Like

Hey neighbors! As Chelsea suggested, you’ll want to reach out to our support team here if your Base Station is not entering pairing mode as it should. @clipboarder Approximately what time did you call? Our support team is available from 3AM-11PM PDT, seven days a week. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19here to see how to contact support.

Sounds like others here have had the same issue
I’m unable to pair my base station with my phone Ring app. Pressing the ‘pairing’ button doesn’t change the blue circle light from being a stationary blue light. I’ve tried unplugging but the internal battery takes over. I’ve also tried pressing the ‘reset’ button. Nothing happens.
To confound the issue I’ve contacted Ring support via the chat function and there is no support on a Sunday early afternoon. They are happy to help with anything else!!!