Ring Alarm Base Station Not Charging While Plugged In

Yeterday, during a thunderstorm, our ring base station notified it was running on batterary back up and cellular back up. We did have a flicker of our lights, so i didnt think much of it till it notified us again that it was running low on power and it was still on cellular back up, which i found odd as the power and internet were both on and working.

The base station is normally connected all the time to power and uses an ethernet cable since its close enought to do so, so there shoul dbe no reason for it to be not connected. I tried to reconnect via ethernet, but it would either freeze or get stuck during set up, so i set it up to WiFi and it connected, but it was still reading as not connected to power/Battery backup power. Now its morning and my system is completely dead, and i cant try to reset the systme, since the system wont even turn on.

Also, i would like to state my displeasure that there is no official technical support from Ring, via phone or chat that could help, and i have to post to a community forumn to get help.

Sorry to hear about this experience, @David20. In the event, that power or network connection is lost, the Base Station should periodically check for the return of the resource. For this reason, the reconnection may not occur right away.

As you mentioned reintroducing the network manually via wifi connection, it should now allow you to switch back to ethernet. Additionally, reintroducing power by unplugging and plugging in the Base Station power adapter should resolve this concern.

If your Base Station is still not responding or powering up, please try another outlet in the home, as a test. Otherwise, a reset may be necessary. As our help center article states a Base Station reset is best done with our support team, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Feel free to let us know how this goes! :slight_smile:

We tried a different outlet with no success, however my wife removed the battery and we regained power very briefly to see the ethernet has reconnected. The problem remains that the base station still is not recieving power from the wire and is now completely dead again.

Is it possible to get a new power cord to see if that fixes the issue?

Thank you for trying those steps, @David20! It certainly sounds to be related to the power adapter. If you’ve checked both ends and tried another outlet to no avail, this concern will need a more in-depth look. Our support team will be happy to troubleshoot further, and are happy to help you obtain a solution. :slight_smile:

I too have this same issue. In So Cal with the heat and fires, power has “blinked” at our property several times. The wall wart power supply is no longer functioning. How do I go about getting a replacement?

FYI, this is a common occurance for these types of power supplies. I work for an ISP and we see this issue all of the time with our equipment.