Ring Alarm base station does not see my wifi


I am setting up Ring Alam at a friend’s house. He has a Cisco WRT320G router broadcasting on both 2.4Ghz and 5Ghz (mixed mode).

When setting up the base station, it does see surrounding WiFi SSID’s, but not his SSID.

Does the base station have any issues with connecting to routers broadcasting in mixed mode?

Any suggestions we can check?


Hi @twcoolen. You can try rebooting your Base Station by taking a pen or a paperclip and quickly tapping and releasing the reset button on the back of it. Do hold this button down, only do a quick press and release to complete the reboot. If it is still not setting up properly, please give our support team a call at one of the numbers available here. They can take a deeper look at this for you and make sure it gets set up properly. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

Resetting the base station did not solve the issue.

What eventually fixed the issue is changing the 2.4Ghz channel from 13 to 10. Channel 13 was not crowded (actually no other users in range) neither was channel 10. However, I suspect that, since channel 13 is not used in the US, this is conflicting in some way.

Immediately after configuring channel 10, the setup could see the SSID.

1 Like