Ring Alarm (2nd Generation) UK plug high pitch sound

Hello,

I set up (on release day) the 2nd gen alarm system. It’s the new plugs that you slide off you and pick your regio (EU, us, UK etc).

On the base station, there is quite a loud high pitch sound when plugged in. I have turned it off so it uses the battery for a bit. I don’t want to send it back as the rest is all now set up and I guess with it being a brand new product, not a lot of people will experience the same!

It seems to come from the actual plug and not the base station. Can anyone tell me the actual plug type it is so I can plug buy a fitted plug instead, the cheaper slide ones don’t fill me with confidence.

Thanks.

DB

Thank you for reaching out, @danielbanks82! We take your safety very seriously, and thank you very much for bringing this to our attention. To help us assess the situation, I’d like to ask you to please reach out to our support team for a more in-depth look.

Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

Hi, I too have bought the 2nd gen in the UK and can hear the high pitch frequency. Let me know if you get any response from support.

Snap, same here. Quite disappointing if this is just a by-product of having the UK adapter in place its very noticeable in a quiet kitchen.

be interested to see if there is a solution

Hi neighbors. Thank you for bringing this to our attention. As mentioned by Marley, this is best handled by our support team. They will be able to diagnose what is happening and take the appropriate action moving forward.