Ring 4 with TP-LINK AX55 router

I got Ring 4 door bell 2 days ago. It was connected with my TP-link Archer AX55. It worked for few hours and then it is completely dead. It could not be connected to the wifi anymore. I tried to reset it but now it could not even find my wifi network.

Is it the problem with my mesh router. I have read a few posts related to this problem. Some people say that disable “fast roaming” may solve the problem. But I couldn’t find it on my router settings.

Is that true Ring doesn’t work on mesh router normally? The problem has lasted few years but it hasn’t been fixed by Ring. Will the new battery doorbell plus work on these type of routers.

Thank you.

Hi @user44961. Mesh systems can occasionally cause connectivity issues with how devices are routed, since it can vary. If possible, I’d recommend creating a guest network utilizing only the 2.4GHz wifi network to try and connect the Doorbell to. This can help provide a more stable signal for the Doorbell to remain connected to, as opposed a dual-band network.

If this issue persists, I’d recommend following up with our support team for more in-depth assistance. You can give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.