Ring 3 Plus wont connect to new Xfinity modems

I was recently sent an “upgrade” of my internet modem from xfinity. Every other IoT device in my house synced fine except the Ring doorbell. I’ve tried dozens of times to reset the network but the device never connects. But it’s weird that it will send motion alerts to my phone, just no videos. And the device status says it’s offline.

Try doing a reset on the doorbell and then connect.

2 Likes

Done it a dozen times, plus received a replacement from Ring. 6x more tries, still no luck.

Hi there, @dthorpe75! This sounds like it might be related to network settings. Here is our help center article about ports and protocols, as well as other tips for adjusting your network if needed.

Our support team is happy to take a further look at this, as well as provide advanced suggestions based on your network details.

Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.