Ring 3 hardwired, not charging

Hello all.
I received a ring doorbell 3 for Xmas. Setup with no problem, battery at 100% when installed.

I saw right from the start no matter what settings I used the doorbell battery would not charge, yes i waited to see if charging would start at 90%, it did not. I checked my bell transformer and seen it was a 16v 10ma unit so I up graded to a 16v 30ma. I am getting 17v at the doorbell, but still losing power, not charging.

With full disclosure our door is a busy door it’s not the typical front door, everybody uses it so I can get 10+videos a day just by motion alone. I do have snapshot capture on, trying the one hour 15 minutes and 5 minutes it doesn’t matter I still lose power.

At this rate I would be lucky if I got 10 days out of the life of the battery

Am I missing something I thought it was hardwired the battery would stay charged no matter what?

(posting from a cell phone sorry about any typos)

Hi @MrSteve65. I appreciate you verifying that you have 17 volts on your wires! Since you do have power at the wires, it should be trickle charging. I would try factory resetting your Doorbell by pressing and holding the setup button for 20–25 seconds and then reconnecting it to wifi, as the reset will cause it to go offline. When you do your reconnection, make sure you have your 5-digit pin code that came with your Doorbell 3, which should be on a slip of paper. If not, it will be on the back of your Doorbell. If you have tried these steps and are still having the same concern, give our support team a call at one of the numbers available here for further assistance. If you are outside of the US, please visit here to see how to contact support.

1 Like

Thank you Justin for your reply.

Yes I’ve tried doing the reset.

I am somewhat convinced that the trickle charge just isn’t enough to keep the battery at a neutral level while the unit is working. I mean I don’t think it takes a rocket scientist to see a transformer that only gives 30ma for charging just isn’t enough regardless of volts, when it takes hours for the battery to charge at 120v 2amp usb charger. I can only assume that the doorbell itself needs more than 30ma to operate, for the sake of argument let’s just say it needs 1amp… well 30ma would never let it charge, it would only delay battery swap/recharge.

If this unit is fine I could never see how this battery would ever last the claimed 2 months on the simplest settings, less power consuming settings when hardwired, maybe a week on battery only.

Hi :wave:. I’ve got same problem with hardwire. Dosen’t charge a batterie . Could be because at a first time I setup with a batteries but not hardwire?

1 Like


You can see if you’re getting Power by looking at the battery icon, if there’s a lightning bolt through it, the doorbell knows it’s hard wired (should be charging). Wired information is also in the health page, it will say ‘hardwired’.

In any case when I did a reset, it was hardwired to the house when I did it, the charging still can’t keep up.

1 Like

I think i have the same issue. Replaced a Ring 2 with a Ring 3. The previous Ring was hardwired for a trickle charge. See the screenshot. The new one, hooked up the same way, does not say hardwired. Instead, it says Battery. Tested with voltmeter and it read 17V. Also tried rebooting the Ring and re-installing the Ring app. Help please.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.