Ring 2nd Gen wont hold a charge?!

I have a 2nd Gen ring doorbell from a few years back that we never used. I “set it up” last year and it worked fine in my house but never installed it as I knew we were going to get a new front door. So now that the door is installed I figured I’d charge it up and mount it. But I had it charging overnight on a USB/cube mount plugged in and it never charged (blue light blinks, never solid). So I tried using my computer for many hours with the same results. I did the whole SET UP again with the orange button and got the white spinning lights and now it works again but ONLY when it stays plugged in to my computer or socket. I did hold the orange button for 20 seconds for a reset but that did nothing!
Is my ring dead?!! Its 2nd gen so I can not change the batteries.
The strange thing is when I go to settings DEVICE HEALTH,…it shows power source as Hardwired, but it is not and never was Hardwired???
And under that tab is BATTERY LEVEL,…and in red it says “Add a battery”
But I can not switch or click on anything in this area to change any of this.
My warranty is well gone so I am curious if my Ring is just “dead” and wont hold a charge,…or if there is 1 more step I can try?!!

Hi @CJ555. You have tried all the steps I would have recommended for your concern; the next best step is to contact our support team for further assistance. Give our support team a call using one of the numbers available here.

1 Like