Ring 2 Setup keeps telling me to connect to network I've already joined.

Hello! I tried to install a Ring 2 Doorbell for my parents. The app tells me to join the “Ring-…” network, even though I have joined it. Repeatedly! I have tried every step I can find online. I’ve restarted the Ring, the phone, the modem. I’ve turned off mobile data and bluetooth on my phone. I’ve tried with another phone. I turned off the advanced data switching. Etc. etc. The ring has the spinning white lights as expected, its broadcasting the network SSID, and my phone is joined to that network, but the app just keeps saying to connect to that network. A hard restart of the Ring didn’t help.

Hey @mkinjubhy. Are you still experiencing this concern? Since you have done all the troubleshooting steps you can do on your end and what I would recommend, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.