Ring 2 Doorbell will not reconnect after power-cut

I have a Ring 2nd Gen battery powered doorbell.

Yesterday I had a power cut which resulted in the device losing connection to the wi-fi, and a day later it has still not reconnected.

I have gone through the process of trying to re-connect via the instructions on the app - press the orange button, search for my network, re-enter password but the device will not connect.

The device then flashes white and tells me “hmmm sometime these things happen etc…Try again”

I tried again still nothing. It implies that there may be something wrong with my internet connection, but there isnt. I have also restarted my router and tried the process again, and also turned off the VPN and the exact same thing happens…IT won’t reconnect.

My other devices in the house reconnect fine, including the phone I use (Android OS) for the Ring App.

This leads me to believe that there is something wrong with the Doorbell itself

Any help appreciated

Hi @Gilln1. Is there a specific direction that the white light is flashing when you get the error? This will tell me the error that the Doorbell is having. You can also try performing a reset on the Doorbell. You can do this by pressing and holding the orange setup button for 20 seconds, then releasing it. Once that is complete, you can attempt the setup again. Let me know if this helps.

Hi Tom it flashes to the left but still nothing happened after I followed the prompts.

However, about 24hrs after I posted this it then suddenly connected again to the wi-fi… I hadnt done anything else to the device.

This same thing also happened recently when AWS had their network outage. So for some reason the device seems to take approx 36hrs to connect to the wi-fi if there is a disconnect…very strange.

The device is still within the period where I can return it so I am inclined to perhaps do that and request a replacement…unless you have any thoughts on why the device may do this

Hi @Gilln1. This may have been caused by some type of wireless interference. Things like wireless printers or even having bluetooth devices nearby can cause issues during setup. When this happens, it’s best to try an isolate the device as best possible and attempt to reconnect. You can try to connect the device to a wifi hotspot to rule out any network concerns. Also, be sure that the Doorbell is as close to your internet router as possible for setup to eliminate any distance issues.

Hi Tom

There is a wireless printer in the same room as the router and the Ring device (when I had taken it off the wall after it disconnected) so maybe it due to that as you say.

Next time I will turn off the printer and see if that does the trick.

Thanks for your help

1 Like

Hey @Gilln1. Absolutely! Hopefully you won’t have to worry about that moving forward.