Ring 2 doorbell not charging

I have a ring 2 doorbell, not hardwired, I was removing it every 6 weeks or so to charge it and never experienced any issues.
Uploaded an update yesterday and left it charging overnight. It’s now got no charge left.
I tried a few different cables to make sure that wasn’t the issue but it’s not taking charge at all. Any help or advice?

Hi @Bhc166. Have you tried resetting the Doorbell? You can do so by holding down the setup button for at least 20 seconds. I’d recommend giving that a try and making sure to try a different power outlet as well when charging the Doorbell. If it still appears to not power on after these troubleshooting steps, please give our support team a call at one of the numbers available here so they can take a closer look at your Doorbell. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. :slight_smile: