Ring 2 doorbell Battery not charging

My Ring 2 Doorbell (Front Door) seems to be just running off battery, despite being properly connected to an energized doorbell transformer. I purchased a new battery and replaced the one in the doorbell, but it also appears to be dropping in charge % like the original battery. Is there some way to resolve this issue?

1 Like

Try doing a hard reset. This happened to me, I noticed that the Ring was not charging and battery charge was going down on a daily basis. After confering with Ring support, doing a hard reset resolved the issue.

1 Like

Did several hard resets. Battery still not charging, voltage % still dropping.

I have had same issues and noticed that doorbell is very hot. Today find out that plastic behind doorbell is melt even outdoor temperature is zero degrees celsius.

I’ve done several hard resets and reinstalled/setup like a new unit in the Ring App. It’s wired to a measured19.2 VAC doorbell transformer but it is still not a charging the brand new battery.

Any more solutions or do I need to get this Ring 2 replaced to keep the battery charged?

Thanks, but not my issue