Ring 2 connecting to echo 5

Hi everyone having problems connecting my echo show 5 to my door bell it’s telling not supported

I am having issues also.

I also am having issues. I also have a fire stick with Alexa and both doors show great on the TV but keeps saying can’t find any of the doors on the SHOW.

Hey neighbors! Our devices are certainly compatible with Alexa enabled devices and skills. Please follow the instructions from our help center article to pair Ring to your Echo device. Let us know how it goes! :slight_smile:

I’m having the same issue. I’ve followed the instructions in the Ring help files and after adding the ring skill in the Alexa app the devices can’t be found.

Both my ring video doorbells are working properly.

Hi neighbors! Thank you for this information. Can you please try these steps and let us know what happens?

Troubleshooting Tip #1:

  • Delete devices from Alexa App, then re-discover devices. Try again.

Troubleshooting Tip #2:

  • Unlink/relink skill. Try again.

Troubleshooting Tip #3:

  • Confirm that 2-way talk works on Ring app. If it doesn’t work on Ring app, the problem is not related to Alexa.

Troubleshooting Tip #4:

  • Ensure the proper voice command is being used (ie: “Alexa, talk to Front Door”).
1 Like

Tip #1
Can’t do because my devices can’t be found by Alexa

Tip #2
I disabled the ring skill from Alexa and then enabled it again, complete with logging into my Ring account through the Alexa app.
Got the same result. No devices found.

Tip #3
Two way talk is working on both my Ring video doorbell 2

Tip # 4
Can’t do because my devices are not found.

Thank you for trying

1 Like

I have a Ring 2 and an Echo 5. The Alexa App detects the doorbell and receives motion and ring notifications. However, when i ask Alexa to show the door to me, it says that no device exists. I went through the troubleshooting process a couple of times.

I’ve got the same problem how can

I’ve got the same problem how can we get it to work

Figured it out. I saw a post on an Amazon forum that talked about the problem. If the Alexa is registered under one user, but the ring is registered under a different user (e.g., husband/wife), you need to factory reset it and make sure both are registered to the same person. I just did that and it works now.

1 Like

Thank you good advice but I’m still getting the same error