Ring 2 audio problems

I have since spoken via e-mail to ring support and gone through various tests and trials and the conclusion from Ring is that my doorbell is faulty.
A replacement is on it’s way shortly but from what they have said could be 2 weeks, I’m not convinced that this will be the problem but we will see when the replacement is fitted.
Watch this space ?

@ Dunclie Hopeful for u. We decided to upgrade and they credited us for our 1st Ring, saying the same. We spent double thinking that might be it, but it still did not work on our phones. iPad and echo shows it does, though. Good luck and pls do let us know!?

1 Like

@Sheteaches, you were correct and as I suspected the replacement arrived today and I installed it but still no audio on my phone from the doorbell.
I have e-mailed details back to Ring so we will wait to see what they say.

2 Likes

It’s so disappointing. Let them know about this thread.

@Dunclie, I am so sorry. We too, are still dealing with the same issue, patiently waiting on a response and fix…:neutral_face:

1 Like

I had before ring 1 . Never had any problem. Now at my new location I purchased ring 2. Wiring is fine. Texted with diode and rings fine. The door bell rings out side. But it is not able to connect to WiFi. It picks the WiFi connection and signal streaming is good then it drops. What is the problem I am facing. Need help

1 Like

The problem is with the bluetooth. On a Samsung phone it sends audio to bluetooth if it’s enabled. Disable your bluetooth and try again. It works great. However, of course, you don’t have anything else that uses bluetooth working now.

Hi, I’m having the same problem too. I have the ring video doorbell 2, I’m on the huawei p smart 2019 phone, I’ve deleted it reinstalled it, then reset it and still having problems. My visitors say it’s like a screeching notice. Can anyone please advise me as I am paying for something of no use to me.

I know in respects to mine I have two mice. One at the bottom of the phone and one at the top. When I talk in the top mic all is good. The blu tooth fix worked for me also.

1 Like

I tried the top mic but didn’t work. The Bluetooth “fix” seems to work but inconvenient.

1 Like

I’m shocked that there is 10 pages of people suffering with exactly the same issues, having to diagnose the issue ourselves, crazy customer service

1 Like

Yes. Not one response from Ring either. It’s truly sad. I keep liking post and responding because if not it just disappears into oblivion.

1 Like

Agreed. I have no idea why Ring is not addressing this issue with fervor. They are losing many, many Android users.

When you do phone ring up they can’t understand you. The only thing they get right is taking your money.

I would also suggest that we all call customer service and mention this long thread. They have to know this is a major issue.

Using IFTTT, I’ve got it setup now that if the doorbell is pressed it will disable bluetooth on my phone automatically, not the best way to deal with it but it’s a start.

It seems theres another 10 page thread running concurrently with this one! The fault finding they have come up with is that is possibly related to android 10?

https://community.ring.com/t5/Video-Doorbells/Doorbell-Pro-2-way-audio-issue/td-p/237

@danfozzy85 After the doorbell rings, do you have to manually reset the bluetooth on your phone each time?

@danfozzy85 I’ve downloaded IFTTT, trying to find how to turn off bluetooth when doorbell rings, have searched and searched. Find how to turn off bluetooth when entering an area or home, but not specifically through the ringing of doorbell. How did you do it? Also, I asked before, but do you have to automatically reconnect it to bluetooth after a doorbell ring? I’m desperately trying to find a fix to the audio problem with my phone and doorbell.

Pull down the top bar. The bluetooth icon is there you can turn off.
Yes, you’ll have to turn it back on when you’re finished.

1 Like

Thanks, I know how to turn off bluetooth, lol. I was referring how to create an applet in IFTT that would automatically turn off my bluetooth when the doorbell rings. I figured it out. Thanks for trying to help! Btw, it does help the audio when bluetooth is off, just didn’t want it off all the time when I am at home bc I have other devices that I connect to with BT.?