Retrofit kit issues

I have the Ring alarm (Monitored) and I have this kit. I have a couple of questions.

  1. I have contact sensors wired to the kit. It’s almost 90% of the time, when I first open a window or a door, I don’t hear any acknowledgement sound. And when I close it, it now registered it as open. If I open and close it a few times, it gets back to working correctly. It’s almost like the sensor is a sleep and then wakes up but the system missed the break in the contact.

What could cause that? I noticed all the sensor leads has a 2200ohm resistor at the end.

  1. Can a powered motion sensor work? I mean, I tried hooking it up to a zone and it seems to register fine. I’m guessing it’s getting power from the old alarm board. So it should be fine to use if I keep the old board with its battery backup and power?

  2. If the alarm is disarmed, and I open the retrofit case, I would get a tamper notification. It did when I was NOT in monitored mode. Will the monitor center call me now that it’s a monitored system?

  3. I have the alarm kit wired to my router with a cat5 so it’s not using wifi. The retrofit kit doesn’t have that option. I noticed in the app, on the retrofit kit picture it will SOMETIMES show a weak wifi signal. So…

a) I added the Ring repeater between where the retrofit kit is and the alarm base is. It’s about 20ft away with a single wall between. And the repeater is right in the middle. I thought that would fix it as the red mark disappeared. But it came back.

b) Is this the cause for my question #1? But weird it’ll work if I open/close the sensor a few times.


New issue.

My retrofit isn’t communicating with the base. I tried to remove it and adding it back. It says it’s not getting a wifi connection. I followed the steps in removing and putting back the batteries. It still won’t find the retrofit kit. Any ideas? I don’t really want to call yet. I was doing the following when that connecting issue happened.

I thought maybe the reason why the sensors aren’t being read is because of having two sensor grounds being shared on the retrofit. So i removed one sensor (#8) and for the 8-C-7, I only have #7 connected to C. If I open the door, the sensor doesn’t register. If I close and open the door, it’ll read the door. It’s like its in some low power mode for the first reading.

Thank you for sharing your experience with the Community @Starstreak! You’ll find the answer to many Retrofit related questions at Here you will find helpful articles about installation, zones, and more.

As this is a neighbor to neighbor Community, keep an eye on this thread to see if any neighbors with a similar setup might be able to share some recommendations.

Our support team is also happy to help, anytime. Feel free to share with us any solutions you’ve found, as it may assist other neighbors in the Community! :slight_smile: