Resetting my Ring System/sensors

Hi,

I somehow had removed my sensors off of the base station. I’ve been pulling my hair out trying to reconnect each and every sensor but still no luck. Also the base station doesn’t pick up my keypad or extender.

I have done the following:
Reboot and reset the Base station
Remove all the sensors and reconnect
Unplugged the extender multiple times
Tried to reset the keypad many times.

Nothing seems to connect.

This shouldn’t be rocket science? Right!

Please can you advise. From poor bloke going bald due to frustration.

Cheers
Nick

Hi @the6redcoats. This Help Center article here may be of assistance, as you’ll need to factory reset all of your sensors. For future reference, the Base Station should never be reset without guidance of a support team agent. If you are still unable to correct this situation, I would suggest reaching out to our support team for the next best steps.

Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.