Reset wifi password and frustration ensues

Okay, so we had a storm, which knocked out the internet. my kids in their infinite wisdom hard reset the router, not realizing that it wasn’t the problem.

Joy.

So… I thought I had put in the same information for the router password, but alas i did not.
note: the old, and new, passwords contain an exclamation mark (!). I Never had any issues setting up the old one with an exclamation mark. never had issues with the cameras choosing 2.4 or 5ghz router choice.
Anyway. every time i follow the instructions in the app, it says I can’t reconnect, because it’s blocked: "we recently blocked an attempt by another Ring customer to set up your Ring device named xyz, which is still currently linked to your ring account.

  1. The tips in the email are dumb. I did not give my device to someone, and didn’t move and leave it behind.
  2. I am the only user on my account. me, myself, and i.
  3. I tried deleting the camera, and starting over, with the same results.

So… how the F do i get the two cameras that i have back online?
I could theoretically put back in the old password, but then i’d have to update a crapton of other wireless devices, and I’m not quite to that level of frustration…yet.

Any help would be appreciated, thanks!

1 Like

okay, i deleted both cameras from my account, i did have another address (duplicate) which I also deleted. don’t ask me why I had a second address. anyway, starting fresh. I did get one camera working again - setup with the new wifi password. no issues whatsoever. but the other one…same dang problem… “blocked an attempt by another ring customer…which is still linked to your account.” I’ve probably tried 7 or 8 times now, with the same failure mode each time. Any ideas?

Hi @intrepid45. It sounds like you may have registered the camera under a different email. I suggest reaching out to our support team to look into this for you. Be sure to have the MAC ID for your device nearby so the support agent can assist you in identifying the registered email. The MAC ID can be located on the back of the device.

Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

Having exactly the same issues after a power cut. Everything else in the house can connect to my wifi but not the Ring device. Same experience by others as evidenced on the Google Play review below.

Now spent ages rebooting wifi, resetting device, even removed device and tried to re-add, now can’t add the device back on my mobile.

Please escalate as this appears to be a fairly common issue and would rather not spend time on the phone going through the same steps with Customer Services that I have tried already. Thank you.

Review: https://play.google.com/store/apps/details?id=com.ringapp&hl=en_GB&gl=US&reviewId=gp%3AAOqpTOG4Gh-f-j20BqYeIdUf_BW7bkKQpvHryp_jrr2AeWz0T7zE0MgmayOw2XX1f8w6QU2Ej-S9hlI2dT-ITQ