Removing a privacy Zone

I’m having trouble removing a privacy zone. The doorbell camera has a zone defined, but does not recognise it as a zone that I can delete.

It does not show up as Privacy Zone 1 (and I can’t tap on it to select it and edit it)
I can create a new Privacy Zone 1 over the top of it and edit that zone (and delete it)

But this other zone still exists, I can’t select it, I can’t edit it or delete it

Has anyone else had this problem?

Hi @Stimo65. Have you tried editing the Privacy Zones on a different smartphone or tablet to see if it still doesn’t let you remove one? Would you mind sharing a screenshot example of the Privacy Zone you’re unable to remove?

I do not have an option to remove a privacy zone, either. Only can add. How can I eliminate the existing privacy zone?

Infocraver -

In the past, when I tried using the Privacy Zone feature, I was shocked at how flaky/unstable it was. (In fact, it was a real nightmare if you attempted to delete privacy zones.) Also, the Privacy Zone feature offered such limited functionality that it was pretty much useless.

It sounds like Ring may not have fixed the problems.

Thus, if Ring ever replaces its current Privacy Zone feature with a useful/stable one… I hope someone reports the details on this website.

Hi @Infocraver. You should have the option to remove a Privacy Zone if you have one set up already. To delete a Privacy Zone, follow the steps below:

  • Open your Ring app.
  • Tap the three-lined menu on the upper left-hand side of the screen to open the side menu.
  • Tap Devices .
  • Select desired device.
  • Tap Device Settings.
  • Tap Privacy Settings.
  • Select the zone you wish to delete.
  • Tap Edit Privacy Zones.
  • Tap the trash can icon.
  • Confirm you wish to delete the zone.

If these steps don’t work, try doing this on a different smartphone or tablet with the Ring App installed (if you have access to one) and make sure your Ring App and phone’s OS are fully updated.