Remove unresponsive device

I have a ring video doorbell 2 which has malfunctioned and is totally non-functional (customer support have tried to fix this but with no success). When I try to remove the device from the location it’s part of, I can’t as the ‘device settings’ gear icon doesn’t open the settings menu so I can’t navigate to ‘general settings’ and ‘remove device’ as all the guidance I can find online suggests.
Any suggestions welcome.

Hi @user33805. I recommend also making sure your Ring app and phone are up-to-date with the latest updates. If you have done this and are still having the same concern, the next best step is to continue to work with our support team to further investigate your concern. Since you have worked with them before, you might be elevated to our more advanced technical team for them to continue helping.

Thanks Justin. I already had the latest version of the app but I tried it again a few days later and was able to remove the device.

2 Likes

Hi @user33805. Glad to hear that you got this resolved.