Receiving “Something went wrong” after deleting videos, past get days. Yet videos get deleted. Bug report

Receiving “Something went wrong” after deleting videos, past get days. Yet videos get deleted. Bug report.


Have you checked to see you have the latest Ring app and phone iOS?

I have been having this exact problem and everything including app and iPhone are up to date. Any ideas when this will be fixed?

1 Like

Hi there, neighbors! Please ensure there is not a vpn enabled on the mobile device. I recommend also attempting this from the Timeline in the Ring app, as well as from the Event History section of the Ring app, to see if there is a different result. As a similar test, try deleting events from your history at, via web browser. Feel free to let us know how this goes! :slight_smile:

Same problem as everyone else. Just fix this bug and stop asking stupid questions!!


I’ve been having the same problem. My iOS & Ring App are up to date & the VPN on my phone has been disabled. The error message only comes out when I delete the events on the dashboard and not when I delete it on each device. I’m guessing it must be a bug. Please fix it!

1 Like

Same issue, everything is up to the latest versions.

Received msg Something went wrong when attempting to delete videos

Cannot select multiple video’s for deletion after last week’s update ("something went wrong error msg). I can manually select individual videos and delete.

Please fix this! :blush:

1 Like

Same issue here for a week or so now

Same error message when deleting all videos with the ring app. The app and IOS versions are the latest after receiving a ring app update a few days back. While it shows all the videos there after the “something went wrong” message, if you refresh the screen by going back one screen and then re-entering, I see that they all have in fact been deleted.

Using IPAD AIr IOS 12.5.4. Worked perfectly until most recent update to Ring program. Now not only does error message occur with delete all function, but some video files won’t download for viewing. And no it’s not my internet speed.

Sorry to hear this concern is persisting. We appreciate your continued feedback on this, neighbors! I’ve shared this with our teams here for further investigation.

Please fully close or force close the Ring app on your mobile device after deleting an event, and the reopen the Ring app to check on the event history. Although you receive an error when attempting to delete, it should be deleting your videos still. We appreciate your patience, while our team investigates and works to resolve this as soon as possible. :slight_smile:

Same here with iPhone 11 Pro.
After the recent ring app update in July the error message “ something went wrong” comes up when deleting all events. But if leave the history and come back they are all gone?

Still not able to delete multiple videos…Please fix this bug

Running iPhone 11 Pro Max on Verizon network using your ring app and I get the same issues. Version 5.41.0

When deleting all videos it comes back with an error “something went wrong”.

However when I log back in they appear to be gone.

I do have
3 floodlights
3 ring drop cams WiFi battery pack
1 ring doorbell version 1.0
1 ring doorbell version 2.0
Ring alarm system and about 50 sensors including 3-4 smoke detectors panic buttons etc

Seems to be a software bug

I’m having the same problem as well as device not picking anything up at all, all settings are correct and WiFi is fine
Please fix the problem

Same issue here as well. The videos delete (using slide and delete all) and then I confirm twice and get the error. The videos do delete but I get ‘something went wrong’. Tried reinstalling the app, no change. IOS 14.6, no VPN etc and yes, I have restarted my phone. It’s a bug, please fix it.

I still have the problem, I get the message “something went wrong” and nothing gets deleted! Please fix this bug!

I have the same problem, but when I open the App again (iPhone) the videos are deleted.

1 Like