Problems with Snooze

Anyone have probelms with the snooze on their ring device not working? Mine has started going off every few seconds and the snooze will not work at all. I tried chatting with support, but could get no answers to anything I asked.

They acted like there was more than one snooze, but wouldn’t answer what the other one was.

Any help would be greatly appreciated, as it will be a few weeks before I can install a new camera system.


I am having the same problem with the newest Android versoin (3.21.0). App is ignoring snooze alerts for my Ring Pro doorbell. Snooze worked on my iPhone, just not Android. I have someone clearing my leaves today, and the alerts are driving me mad…

1 Like

I have always used android and until now no problems with snooze. Many other problems with the system, but not snooze until now. Support said there was more than one snooze, but wouldn’t tell me what they were.

1 Like

Hey neighbors! If the snooze feature is not saving or functioning as expected, I recommend uninstalling and reinstalling the app. Please also ensure no other apps or connections (BlueTooth, VPN, etc) could potentially be interfering with app operation. Please let me know how this goes! :slight_smile:

1 Like

Thanks for the suggestion Marley_Ring. I actualy just cleared cache and data and re-logged in and set up which I find usually is equivelent to uninstall/reinstall, and snooze appears to be working (with my one test anyway)

I can’t get mine to snooze either.

Same issue here on Android but it’s only not working when trying to activate it directly from the motion notifications (see attached). If I open up the actual app, go to the device then motion snooze section - it works from there.

1 Like

I started having the same problem about a week or so ago - I have to snooze multiple times before it will accept the instructions to snooze - sometimes only 2 or 3 times, sometimes I just give up - this is detracting from being able to use the devices as intended.

Same issue still occuring

Snooze works if enabled directly from the app but does not work if enabled from motion alert notifications. Using Android - Ring app version 3.21.1

Reached out to Ring support and they just want basic things done which I have already tried

Reinstall app, clear cache…


Hi all - Just FYI that this problem is suddenly occurring for me on iOS, so it seems to be a platform neutral issue (an incredibly annoying one). Likewise, in-app snooze does at least work. It’s just the notification/pop-up snooze that is suddenly broken.

Seems to be a problem since they forced multi factor authentication. As when I turn it off my snooze from notifications works.

Oh, interesting. I’ve had multi-factor in effect since long before them making it mandatory (if that’s what you’re saying they did), but it certainly only started recently and may indeed have started at that same point.

Still not fixed. This is tremendously annoying.

It seems to be working for me since the last app update. Will have to double check. I have Ring app ver 3.22.1 on Android with 2 factor authentication enabled

Okay, well maybe it’s an iOS thing. I’m on the latest version as well, which is 5.22.4 on iOS.

Hey @houseofg! Thank you for keeping us updated on your concerns with your snooze feature. If you have not removed and reinstalled the Ring app since the most recent update, it’s always worth a try, as is trying on wifi or cell data only.

I will certainly share your feedback with the appropriate teams for further investigation into this matter. As always, our support team is available for more in-depth troubleshooting as well.

1 Like

You know, I almost wrote this off as a canned response akin to “have you tried a reboot?”, but figured what the heck, why not try an app delete/reinstall. That does indeed seem to have fixed it. Thank you!

1 Like

I am also experiencing Snooze feature not working with either my spotlight cam or video doorbell. Have you heard back from Ring? This seems to be a classic example of a company not testing their product inhouse but instead relying on the the public to test. Totally unacceptable. I cannot recommend these products. Ring does not seem to have a contact point to report software bugs. Typical!!

1 Like

They are noticed here and reported by Ring staff, after that who knows. Fixes do come out but there are still many that have not been fixed yet sadly. You can call customer service and tell them as well. Hopefully this is fixed soon. I don’t like not being able to quickly snooze the notifications if I’m at work and don’t want to be bothered by landscaping crews and such.

Hi. Yes, see their response and my response, above. Deleting and reinstalling the app seems to have done the trick. I didn’t even lose my settings.